Changing Instance IP Binding / URL

OS Name/Version: Ubuntu 20.04.3

Product Name/Version: AMP Instance Manager v2.3.1 built 13/01/2022 21:17

Problem Description: Had to change AMP ADS URL for re-config on router and port forwarding.

Was successful in changing ADS URL to

Instance Satisfactory01 is still using old binding

Attempted to use:

ampinstmgr --ReconfigureInstance Statisfactory01 8081

However on start of ADS the Satisfactory instance is still tied to URL in:

ampinstmgr --ShowInstancesList

Is there a different command or place in the ADS manager that I can change this?

A new instance does bind to the New URL but I’d rather not rebuild SteamCMD again
as that took multiple days to figure out all the terminal commands to create/move files
so that the Satisfactory Instance would work properly.

(I do intend to create another forum post about that later so others don’t have to go
through the same pains)

Any help would be appreciated.

– Update –

Is it possible to rebind an instance to a static IP?

I’ve been able to resolve the Instance management issue for now - my router is seperate from this app so I’ll keep on that.

For reference:

Router lost connection to device - could still see MAC Address

  • Restarted Network switch
    -Still couldn’t see so opened to DHCP
    -Router saw device, however after setting back to old Static address Router was stuck on DHCP address
  • Rebound AMP to new address
  • Instance would fail to start
    ampinstmgr --ShowInstancesList would return instance listening on old IP Address
  • instance would also fail to launch management GUI saying it was not Active

Attempting to get my router to find system on old address but if I cannot would be helpful to rebind instance to new IP

If not possible no worries! I’ll start from scratch on the new IP.

Recreating the instance will be easier than troubleshooting my router software.


You shouldn’t rebind instance IPs unless you have multiple network cards in your system normally. is the default which makes applications listen on all available addresses.

Please reply to posts using actual replies rather than editing your original post.

You don’t need to tell AMP to use your static IP at all, like I said - makes it listen on any available interface. Don’t rebind AMP at all unless you have multiple network adapters.

This sounds like just a configuration issue with your router. You should make sure that the static IP you assign to your machine is outside of the routers DHCP range.