Change docker instance backup location

OS Name/Version:
Ubuntu Server 20.04.5 LTS / AMP Halimede v2.4.0.10

Problem Description:

I run AMP in a dedicated VM with minimal storage, just enough to run the instances I need. So I have all of my backups setup to an auto mounting directory on a local NAS. This has always worked for instances not using docker. However Satisfactory saves its world outside of the instance so I need to run it in docker to have its save within the instance virtualhome. Editing the LocalFileBackupPlugin file to point to that mounted directory doesn’t work for docker instances though. It will just sit saying creating backup but never progress or say anything more in the log.

It makes sense since that’s not a directory in the container. Is there any way to allow the docker instance to backup to that directory?

Steps to reproduce:

Edit LocalFileBackupPlugin to backup to a directory on the machine.
Run instance in docker and try to backup.

Actions taken to resolve so far:
Test backups are functioning properly when instance is not using docker.
Backup will work within docker if the backup is left at default location.

I think this applies here. Unfortunately you can’t mount to places outside of Docker yet.