Cant update AMP to latest version and update my minecraft servers?

OS Name/Version: Ubuntu server 20.04LTS

Product Name/Version: 2.4.3

Problem Description:

Cant update AMP to latest version.
Tried GUI and terminal prompt

Found that I needed to validate license again (Some time since I used my AMP)
Why does it say 8 of 5? (Only running one server!)

Old install had wrong gateway I updated that on the Ubuntu and I can update apps.
But running the update of AMP I get these errors:

Interesting i had the same issue, I had to reinstall ubuntu and reinstall amp, looks lioke the old updates are broken but new versions you can update via the web gui

Anyway to save all my game servers?
Can I fix it on the existing server?

idk about fixing on existing server, but what i would is download the latest backup from each instance, before you wipe. someone more clever then me may have a way to fix. but as long as your not on baremetal and using a vm i would start rerolling,

I tried the:
ampinstmgr --nocache upgradeall
But even after download it dosent upgrade through the terminal.

Hmm yes I guess I could restore them as backups, but the whole reinstall would take a looong time.
So you say some update broke the install and future upgrade process?

maybe try the steps here

CubeCoders | AMP Installation

, but i found when i ran update from package manager it was not pulling the latest version

sudo su -l
bash <(wget -qO- addRepo
apt update && apt dist-upgrade -y
sudo su -l amp
ampinstmgr upgradeall
you will be up to date if you follow this.

1 Like

You are my new HERO!

That worked like a champ!
Only got one error/wraning?
Can’t find custom attr constructor image: /opt/cubecoders/amp/plugins/ADSModule.dll mtoken: 0x0a00001e due to: Could not load file or assembly ‘SQLite-net, Version=, Culture=neutral, PublicKeyToken=null’ or one of its dependencies.

don’t worry about it at all. your good

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.