Can't start V-Rising instance | Docker | Centos8 Stream | - Mainline

OS Name/Version: Centos8 Stream

Product Name/Version: AMP - Mainline

Problem Description: Game server crashes before fully starting, actually similar to this thread [Can’t start V-Rising instance] except I’m running CentOS and not on a VPS

C:\windows\system32\mpr.dll:mpr.dll (00007F4B32DF0000), size: 151552 (result: 0), SymType: '-deferred-', PDB: 'C:\windows\system32\mpr.dll', fileVersion: 5.0.2195.6611
========== OUTPUTTING STACK TRACE ==================
RtlLookupFunctionEntry returned NULL function. Aborting stack walk.

You can see full output here

Steps to reproduce:

  • Login to AMP and create V-Rising server as a container
  • Manage V-Rising instance and click on console tab.
  • Click update button in console tab then click start once update is done.

Actions taken to resolve so far:

  • Uninstalled manual docker installation and installed using bash <(wget -qO- installDocker and verified working Docker version 20.10.17, build 100c701
  • Had previously installed wine manually to get server working (before moving to docker instances), removed it just in case
  • Verified docker isn’t the issue by creating a containerized Satisfactory game server and worked just fine (no errors in console and able to connect to it)

In an effort to save time, providing output of commands asked for in the similar thread listed at the beginning of post

[root@smoothsailing ~]# docker --version
Docker version 20.10.17, build 100c701
[root@smoothsailing ~]# su -l amp
[amp@smoothsailing ~]$ docker pull cubecoders/ampbase:wine
wine: Pulling from cubecoders/ampbase
Digest: sha256:e8c3180bbfba2762b91fec0effcd97fdf91aec459267bc31968894fc9353c117
Status: Image is up to date for cubecoders/ampbase:wine
[amp@smoothsailing ~]$ ampinstmgr restart vrising01
[Info] AMP Instance Manager v2.3.4.2 built 11/07/2022 20:17
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] Stopping Instance: 'VRising01'
[Info] Stopping instance VRising01...
[Info] Instance VRising01 has stopped.
[Info] Starting Instance: 'VRising01'
[Info] 1421d915467a157693c0a516154d5ca90a19ac13f690b00d6225352d65f8674c
[amp@smoothsailing ~]$ ampinstmgr validate vrising01
[Info] AMP Instance Manager v2.3.4.2 built 11/07/2022 20:17
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] 0 missing files, 0 damaged files.
[Info] All files passed OK!

UPDATE: While trying to answer Can you make a new instance for me and check that two instances fail in the exact same way? The previously failing seems to work now once I started the second server but the second server is failing the same way the first server did. It’s as if the second one is being sacrificed in order for the first to work

@IceOfWraith this one’s for you

I apologize! I got logged out on my phone and didn’t realize it so didn’t see this until now. If this is still an issue, have you tried deleting and recreating both instances?

I did, but what’s interesting is the first one occasionally works now. I stopped the second one thinking the issue was fixed and restarted the first one but first one went back to failing multiple times.

I tested this multiple times, but as long as the second one starts and fails, the first one has a chance of working VS first one never works if it’s the only v-rising instance running.

I have the same problem, when the server goes down and I try to get it up again it gives an error. If I stop the instance and start it again, the server starts the first time.

I just realized you said this was on CentOS. For some odd reason Docker V Rising on AMP behaves very strangely. I’m wondering if Docker is configured differently in that distro. Because the container should work identical on each platform/OS/anything.

Can you share the log? And now I’m adding random text to meet the 25 character requirement. Lol