Cant install custom jar file (Magma jar)

OS Name/Version:
Ubuntu 20.04.5 LTS | 16GB RAM
Intel Core™ i5-2500 (4C\4T)

Product Name/Version:

AMP Release “Halimede”

v2.4.0.10, built 27/10/2022 18:15

Problem Description:

Hello dear AMP team,

I would like to install a custom jar (Magma-1.18.2-40.1.84-713f632c-server.jar). I have previously made the following settings:

Java version 17
Ram: 5GB
Server Arguments: -Xmx{Memory}M -jar {JarFile}

When I start the server for the first time, I am asked for the EULA, after I have accepted it, the server crashes and every time I start it again.

The error message looks like this:

Error: Main class Magma-1.18.2-40.1.84-713f632c-server.jar could not be found or loaded.
Cause: java.lang.ClassNotFoundException: Magma-1.18.2-40.1.84-713f632c-server.jar

A log is not produced. If I execute the .jar file normally, i.e. with the help of an SH file, the whole thing also works. The content of the SH file looks like this: java -jar Magma-1.18.2-40.1.84-713f632c-server.jar

Many thanks in advance :slight_smile:

Kind regards

Steps to reproduce:

Load the file, and try starting it

Actions taken to resolve so far:
Tried different Java versions
Tried different Arguments
Started the server without using amp, and istead using a sh file

Make sure to delete the libraries folder before starting Magma, or it it just doesn’t work (weird, I know).
My args: -Xmx{Memory}M -Xms{Memory}M -jar {JarFile}
(don’t think it’ll actually make a difference)
Overall your setup looks solid. If it still doesn’t work I’d suggest spinning up a fresh instance and testing it over there to see if you get the same result.

Edit: also make sure you’re using SFTP to transfer files