Can't Connect to Server | Unraid/AMP Docker | (Newbie at this)

Hello everyone!

Problem Description:

I’m trying to get AMP working but never worked with things like this, had a spare computer sitting around figured id experiment with things i’m completely unaware of… I installed Unraid, Downloaded the AMP Docker… I followed a guide so i believe everything was setup from a installation stand point correctly. Wanted to run a game server on it just to see if everything it actually working… Loaded up Minecraft seems everything is working but its not connectable by game client… Game Instance Console I see no errors.

I’ve port forwarded everything to my knowledge, I’ve port forwarded/game hosted before on my Main PC but nothing through a system like Unraid/Amp so I’m out of my depth…

I’ve followed guides on getting me to connect to my external IP and Local with nothing working.
One guide had me set up a DNS and VPN and connect via that, which is all very new to me also. I’ve never worked with networking things similar to this so still learning.

OS	Linux
Platform	Ubuntu 20.04.5 LTS
System Type	x86_64
Virtualization	Docker
Module	MinecraftModule
Loaded Plugins	FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
Application Name	AMP
Application Version	2.4.2.0
Release Stream	Release
Build Date	21/02/2023 11:49
InstanceID	3b365b44-f1ff-4d94-81a3-032002d83740
Last Executable	/usr/lib/jvm/java-17-openjdk-amd64/bin/java
Last Arguments	-Xmx1024M -jar minecraft_server.jar nogui
Last Process ID	8386

Running AMP inside docker is unsupported, you’ll need to refer to the image’s own documentation here: GitHub - MitchTalmadge/AMP-dockerized: CubeCoders AMP in a Docker Image. Easily create game servers for games like Minecraft, GMod, TF2, Factorio, and StarBound!

You likely just forgot to add port bindings from the container to the host, which is covered in their documentation.

I personally run an Unraid media server and was using a Windows VM to run AMP just fine. Do not mess around with running AMP inside of the unofficial docker (or any docker). Dockers get messed up when they do not have the correct root privilege’s.

Install a Windows VM. Use Network and Sharing center to set a static IPv4. Port forward that IPv4 via your routers WAN Port Forwarding menu. Then run AMP out of that VM headless.