Can't connect to Minecraft Bedrock 1.19 Spitgot localhost on an 8GB RasPi

  1. Installed Ubuntu 20.04.4 LTS with the Pi-Imager on to an SD-Card. (The Pi is connected via ethernet cable)
  2. Run bash <(wget -qO- as root
  3. Selected Password for AMP System user and AMP Controlpanel
  4. Yes for installing Java
  5. Yes for 32-bit libraries for srcds servers
  6. No to HTTPS
  7. Enter Installation started
  8. Browser Setup
  9. Choose Standalone(Default) for the ADS Setup
  10. I have entered my license
  11. Create a new instance of Minecraft Bedrock
  12. Go into the manage section and choose spigot
  13. Update… Successful
  14. Starting Server successful
  15. Portfowarding the given Ports which are 19133 for TCP and UDP for the local IP of the RasPi 192.168… at the Router
  16. Try to connect to does not work
  17. Try to connect to the IP of the RasPi does not work
  18. Adding rules at my client’s firewall where I want to play. Adding port 19133 TCP and UDP for inbound and outbound.
    Try 16 and 17 again does not work

After that, I did the same on my dedicated server (Windows) there it works (with and without HTTPS)

Can someone help me? Is HTTPS required? Or am I doing something wrong?

Did you choose Minecraft Java Edition? They’re the same module but not sure if Bedrock actually configures it properly.

No, I did choose the Bedrock Edition (It’s also written on the instance picture), and because I was frustrated I tried the same Process with the Java Version and there it works.

If necessary or helpful I can share screenshots of my configuration for the Bedrock Edtion.

After Edit:

Just to be a bit more precise,

I now have two SD-Cards both 64GB.

  1. Is running AMP with Minecraft Java (Spigot 1.19) which works fine
    and the other
  2. Is running AMP with Minecraft Bedrock (Spigot 1.19) which does not work at all

I also tried older releases (1.18 and 1.18.2)

I did not change any of the default settings
(except that I gave the instance more Memory 5048, changed the MOTD(Headline) to TEST, choose the following Seed 867677604900324654 which works fine at normal Bedrock World, and changed the Java Version to JDK 17 because the default JDK Version was too “old” for Spigot (Java and Bedrock))

When I insert the Java SD-Card it gets the same IP as the Bedrock and forwarded the given ports which are 25565 TCP and UDP…

And that works for JAVA BUT the same DOES not work with Bedrock, why so ever

Just for clarification:

  1. Both Minecraft Clients are legit copies on the newest release (10 pm 10.06.22 CEST)!
  2. AMP is also running on the current version
  3. I CAN connect to other Server on the Bedrock Client

As mentioned above I would agree to share a screenshot or even record the procedure, if that would be helpful.

Thanks for your help
Greetings :wink:

Bedrock doesn’t support mods. You can only use that on Java. Bedrock does have addons you can download and put on it but it’s not the same as a mod.