Can't connect to AMP minecraft server after updating to new paper and java versions

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

Make sure you search before posting! Duplicate posts for the same issue may not be answered.

OS Name/Version: Unraid 6.12.4 host with windows 11 client

Product Name/Version: (Always use the full version number - not ‘Latest’) AMP Release “Callisto”
v2.5.0.8, built 02/05/2024 04:53

Problem Description:
I run a local at home minecraft server for me and the kids. We wanted to update to the new version since we hadn’t played in a few months. I updated the docker image, followed by the amp version, next the paper server version, and java selected as 21. The server runs and the logs seem clean; however, nobody can connect. I’ve even disabled all firewalls and tried to no avail. The server logs are here:

Starting org.bukkit.craftbukkit.Main

21:39:53

System Info: Java 21 (OpenJDK 64-Bit Server VM 21.0.1+12-LTS) Host: Linux 6.1.49-Unraid (amd64)
Loading libraries, please wait...

INFO
21:39:58

Environment: Environment[sessionHost=https://sessionserver.mojang.com, servicesHost=https://api.minecraftservices.com, name=PROD]

21:40:01

Loaded 1175 recipes
Loaded 1276 advancements
Starting minecraft server version 1.20.6
Loading properties
This server is running Paper version git-Paper-78 (MC: 1.20.6) (Implementing API version 1.20.6-R0.1-SNAPSHOT) (Git: 3fc9358)

21:40:02

Server Ping Player Sample Count: 12
Using 4 threads for Netty based IO

WARN
21:40:03

[!]: The timings profiler has been enabled but has been scheduled for removal from Paper in the future.

Console
21:40:03

We recommend installing the spark profiler as a replacement: https://spark.lucko.me/
For more information please visit: https://github.com/PaperMC/Paper/issues/8948

INFO
21:40:03

[ChunkTaskScheduler]: Chunk system is using 1 I/O threads, 3 worker threads, and gen parallelism of 3 threads
Default game type: SURVIVAL
Generating keypair
Starting Minecraft server on 127.0.0.1:25565
Using epoll channel type

21:40:04

Paper: Using libdeflate (Linux x86_64) compression from Velocity.
Paper: Using OpenSSL 3.0.x (Linux x86_64) cipher from Velocity.

WARN
21:40:04

[org.bukkit.craftbukkit.legacy.CraftLegacy]: Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!

21:40:12

Legacy plugin SimpleTrash v1.0.2 does not specify an api-version.

INFO
21:40:12

[floodgate]: Loading server plugin floodgate v2.2.3-SNAPSHOT (b103-f8c8418)

21:40:14

[floodgate]: Took 1,563ms to boot Floodgate
[spark]: Loading server plugin spark v1.10.34
[ChestSort]: Loading server plugin ChestSort v14.0.3
[Geyser-Spigot]: Loading server plugin Geyser-Spigot v2.3.1-SNAPSHOT

21:40:15

[Geyser-Spigot]: Loading extensions...
[Geyser-Spigot]: Loaded 0 extension(s)
[SimpleTrash]: Loading server plugin SimpleTrash v1.0.2
[WildTeleport]: Loading server plugin WildTeleport v0.1
[Backpacks]: Loading server plugin Backpacks v2.2.2
[VillagerEnchantments]: Loading server plugin VillagerEnchantments v1.1.1
[Warps]: Loading server plugin Warps v2.0.7
[UltimateTimber]: Loading server plugin UltimateTimber v1.1
Server permissions file permissions.yml is empty, ignoring it
Preparing level "ColemanWorld"

21:40:16

Preparing start region for dimension minecraft:overworld

21:40:17

Time elapsed: 1531 ms
Preparing start region for dimension minecraft:the_nether

21:40:18

Time elapsed: 447 ms
Preparing start region for dimension minecraft:the_end
Time elapsed: 168 ms
[floodgate]: Enabling floodgate v2.2.3-SNAPSHOT (b103-f8c8418)
[spark]: Enabling spark v1.10.34

21:40:19

[spark]: Using Paper ServerTickStartEvent for tick monitoring
[spark]: Starting background profiler...
[ChestSort]: Enabling ChestSort v14.0.3

21:40:20

[ChestSort]: Use permissions: false
[ChestSort]: Current sorting method: {category},{itemsFirst},{name},{color},{customName}
[ChestSort]: Allow automatic chest sorting:true
[ChestSort]: |- Chest sorting enabled by default: false
[ChestSort]: |- Sort time: close
[ChestSort]: Allow automatic inventory sorting:true
[ChestSort]: |- Inventory sorting enabled by default: false
[ChestSort]: Auto generate category files: true
[ChestSort]: Allow hotkeys: true
[ChestSort]: Hotkeys enabled by default:
[ChestSort]: |- Middle-Click: true
[ChestSort]: |- Shift-Click: true
[ChestSort]: |- Double-Click: true
[ChestSort]: |- Shift-Right-Click: true
[ChestSort]: Allow additional hotkeys: true
[ChestSort]: Additional hotkeys enabled by default:
[ChestSort]: |- Left-Click: false
[ChestSort]: |- Right-Click: false
[ChestSort]: Check for updates: true
[ChestSort]: Check interval: 4 hours (4.0 seconds)
[ChestSort]: Categories: 900-weapons (6), 905-common-tools (4), 907-other-tools (6), 909-food (33), 910-valuables (47), 920-armor-and-arrows (9), 930-brewing (18), 950-redstone (23), 960-wood (60), 970-stone (38), 980-plants (50), 981-corals (1)
[Geyser-Spigot]: Enabling Geyser-Spigot v2.3.1-SNAPSHOT
[SimpleTrash]: Enabling SimpleTrash v1.0.2*
[WildTeleport]: Enabling WildTeleport v0.1
WildTeleport Enabled
[Backpacks]: Enabling Backpacks v2.2.2
[Backpacks]: - Version: 2.2.2 Enabled - By Ib
[VillagerEnchantments]: Enabling VillagerEnchantments v1.1.1
[Warps]: Enabling Warps v2.0.7
Warps has been successfully enabled!
[UltimateTimber]: Enabling UltimateTimber v1.1
[Geyser-Spigot]: ******************************************
[Geyser-Spigot]
[Geyser-Spigot]: Loading Geyser version 2.3.1-SNAPSHOT (git-master-4d61766)
[Geyser-Spigot]
[Geyser-Spigot]: ******************************************

21:40:27

[Geyser-Spigot]: Started Geyser on 0.0.0.0:19132
[Geyser-Spigot]: Done (6.595s)! Run /geyser help for help!
Starting GS4 status listener
Thread Query Listener started
Query running on 127.0.0.1:25565
Running delayed init tasks
Done (25.474s)! For help, type "help"
Timings Reset
[Backpacks]: Backpacks is up to date

21:55:00

Stopping the server
Stopping server
[UltimateTimber]: Disabling UltimateTimber v1.1
[Warps]: Disabling Warps v2.0.7
[VillagerEnchantments]: Disabling VillagerEnchantments v1.1.1
[Backpacks]: Disabling Backpacks v2.2.2
[WildTeleport]: Disabling WildTeleport v0.1
[SimpleTrash]: Disabling SimpleTrash v1.0.2
[Geyser-Spigot]: Disabling Geyser-Spigot v2.3.1-SNAPSHOT
[Geyser-Spigot]: Shutting down Geyser.
[Geyser-Spigot]: Geyser shutdown successfully.
[ChestSort]: Disabling ChestSort v14.0.3
[spark]: Disabling spark v1.10.34
[floodgate]: Disabling floodgate v2.2.3-SNAPSHOT (b103-f8c8418)
Saving players
[Geyser-Spigot]: The skin uploader has been closed
Saving worlds
Saving chunks for level 'ServerLevel[ColemanWorld]'/minecraft:overworld
[ChunkHolderManager]: Waiting 60s for chunk system to halt for world 'ColemanWorld'
[ChunkHolderManager]: Halted chunk system for world 'ColemanWorld'
[ChunkHolderManager]: Saving all chunkholders for world 'ColemanWorld'
[ChunkHolderManager]: Saved 3 block chunks, 101 entity chunks, 2 poi chunks in world 'ColemanWorld' in 0.08s
ThreadedAnvilChunkStorage (ColemanWorld): All chunks are saved
Saving chunks for level 'ServerLevel[ColemanWorld_nether]'/minecraft:the_nether
[ChunkHolderManager]: Waiting 60s for chunk system to halt for world 'ColemanWorld_nether'
[ChunkHolderManager]: Halted chunk system for world 'ColemanWorld_nether'
[ChunkHolderManager]: Saving all chunkholders for world 'ColemanWorld_nether'
[ChunkHolderManager]: Saved 9 block chunks, 86 entity chunks, 0 poi chunks in world 'ColemanWorld_nether' in 0.09s
ThreadedAnvilChunkStorage (DIM-1): All chunks are saved
Saving chunks for level 'ServerLevel[ColemanWorld_the_end]'/minecraft:the_end
[ChunkHolderManager]: Waiting 60s for chunk system to halt for world 'ColemanWorld_the_end'
[ChunkHolderManager]: Halted chunk system for world 'ColemanWorld_the_end'
[ChunkHolderManager]: Saving all chunkholders for world 'ColemanWorld_the_end'
[ChunkHolderManager]: Saved 1 block chunks, 51 entity chunks, 0 poi chunks in world 'ColemanWorld_the_end' in 0.04s
ThreadedAnvilChunkStorage (DIM1): All chunks are saved
ThreadedAnvilChunkStorage: All dimensions are saved
Flushing Chunk IO
Closing Thread Pool
Closing Server

The client logs are here:

[21:57:31] [Render thread/INFO]: Connecting to xxx.xxx.2.181, 25565
[21:57:33] [Server Connector #1/ERROR]: Couldn't connect to server
io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: getsockopt: unifi/192.168.2.181:25565
Caused by: java.net.ConnectException: Connection refused: getsockopt
	at java.base/sun.nio.ch.Net.pollConnect(Native Method) ~[?:?]
	at java.base/sun.nio.ch.Net.pollConnectNow(Net.java:682) ~[?:?]
	at java.base/sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:973) ~[?:?]
	at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:337) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:334) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:776) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:724) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:650) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:562) ~[netty-transport-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.util.concurrent.SingleThreadEventExecutor$4.run(SingleThreadEventExecutor.java:997) ~[netty-common-4.1.97.Final.jar:4.1.97.Final]
	at io.netty.util.internal.ThreadExecutorMap$2.run(ThreadExecutorMap.java:74) ~[netty-common-4.1.97.Final.jar:4.1.97.Final]
	at java.base/java.lang.Thread.run(Thread.java:1583) ~[?:?]
[21:57:38] [Render thread/INFO]: Stopping!
Process exited with code 0.

Actions taken to resolve so far:

I verfied the port forwards are enabled on the router. I verified the host computer is java21 and updated all server files to the latest. I verified the client files are up to date and their firewalls are off. I even “allowed application” through the firewall and added every version of java.exe and javaw.exe I could find on my system to public and private network.

Please see attached pics:

What am I missing?

The unofficial Docker container isn’t a supported setup due to weird networking issues that often arise. It’s recommended that you run AMP in a Debian/Ubuntu VM on Unraid.

Thanks for letting me know. I’m hopeful I’m NOT the only person here using AMP and unraid this way. Maybe someone else here will chime in with their experience and solutions? I am sad this worked fine on 1.19 for a long time and now it’s broken. I believe it would stem from the switch to java21 and unraid/firewall perms somehow.