Cannot get into game from server list V- Rising but can when using server IP

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version:

Windows Home

Product Name/Version: (Always use the full version number - not ‘Latest’)


Problem Description:

Hi everyone :slight_smile:
hope you can help me as im going out of my mind lol

i have installed amp and V Rising instance without issue, all seems ok whilst looking at the dashboard.

my issue is that my server shows up in the server list in game but times out and wont connect… unless i put my ip of my server in then it connects and runs fine

I have opened the ports on my router 9876 9877 UDP and added outbound and inbound rules using Windows Defender. Still the same.

I have tried uninstalling the instance and starting fresh, same issue

I have followed this guide and says that if i can get the game to work directly amp must be working ok but im completly stumped :frowning:

When i run ampinstmgr ports i get this…

info… instance is currently not running? although it is and ive been in game?
listening 8081 TCP
listening 9876 UDP
listening 9877 UDP
listening 25575 TCP

Warning some of the ports required by thisinstance are currently in use (in yellow)

I have tried to chance ports (9876 9877) in amp and updated the port forwarding on the router and windows firewall, still same issue

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Step 1 tried to change ports still cant access server through server list
  • Step 2 reinstalled instance
  • Step 3 followed Diagnosing Connectivity Issues

Actions taken to resolve so far: all above,

I really would appreciate any help, im not very techie, have used amp in the past with success so really not sure what could be the issue :frowning:

Thanks a lot for any help offered :slight_smile:

Ignoring that AMP is out of date, this is fairly normal. Most in-game server lists don’t work that well and don’t list all available servers because there’s so many of them, so joining by IP is often necessary. If you can connect by IP at all then everything is working properly.

1 Like

Thanks Mike.

I can see my server listed when I search for it but when I click the join button it just tries to connect then times out.

I can connect to the server using the internal IP but Im not sure if anyone else would be able to connect if I can’t from the server list if that makes sense.

Not sure why it’s out of date I installed it this afternoon, maybe I need to take a look :slight_smile:

Thanks a lot for taking the time to reply and help it’s very much appreciated

That implies that your port forwarding isn’t configured correctly.

I have been on my talktalk forum and asked if my ports are ok and ran a netstat -a | find “9876”

they seem to think the ports are ok.

I have also tried disabling windows defender and no change.

So if i got in V- Rising and direct connect to my server pc i get in absolutly fine

If i search for my server in the server list, i find it no problem and when i click join it eventually times out and wont connect :frowning:

Any Ideas?

Appreciate it guys :slight_smile:

What happens if you use a connection other than your standard one (say, from your phone) and connect using your external IP? Not all routers support NAT reflection.

Hi Mike sorry I’m confused. How do I connect from my phone via IP? I don’t have the game on my phone, guessing you don’t mean that. Please can you clarify. I very mu h appreciate your time. Not sure how to test the game works outside of my network.

Thanks a lot Mike

I mean using the phones internet connection via USB/wifi tethering so that you’re connecting from outside your network.

Thanks so much Mike! Works absolutely perfect whilst connected via my phone.

So others must be able to access it and I can use the direct connection when I want to play inside my network. :slight_smile:

Appreciate everything and keep up the good work :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.