Cannot change region for S3 cloud backup

OS Name/Version: Ubuntu 21.10

Product Name/Version: AMP Release “Halimede” v2.4.0.10, built 27/10/2022 18:55

Problem Description:

I can’t change the region when adding a new S3 cloud backup, the region is locked to “us-est-1” as shown in this screenshot:

The region parameter is required for the bucket I use

Steps to reproduce:

  • Adding an S3 bucket to the “cloud backup” section of a Minecraft instance configuration
  • Trying to “Upload to S3” a backup

Actions taken to resolve so far:

  • Tried to find the S3 region option in amp instance configuration
  • Tried to find the S3 region option in amp instance config files

AMP doesn’t use S3 regions at all, you have to give it the actual URL of the region you want to use under the “S3 Service URL” setting. E.g. http://s3-website.us-west-2.amazonaws.com/ or https://eu-central-1.linodeobjects.com/

Thanks for the response
That’s exactly what I’ve done
image

Sorry for the region change, I’ve used a different bucket for testing in my original post, but the issue remains the same.

Looks like an OVH specific implementation issue then. We’ll have to look at that.

1 Like

Next update has a setting to allow the authentication region to be set for providers that require this.