Can not SFTP to minecraft directory - all other subdirs work fine for sftp

OS Name/Version: Ubuntu 20.04.5 LTS 5.4.0-126-generic

Product Name/Version: AMP

Problem Description:

I created Fabric Server Instance (Server Settings: Fab M V: 1.19.2, Loader: 0.14.9, Installer: 0.11.1)
Started Server
SFTP’ed into server minecraft directory (root). All is well.
copied my modpacks mods/default config/config folders over.
removed world directory and restared server
Connected with client and ran for server for about a half hour. All is well (great performance).

Next day. stopped server to add mods.
SFTP’ed into server root (minecraft directory)…

This is the error in WinSCP:

General failure (server should provide error description).
Error code: 4
Error message from server: I/O error

Common reasons for the Error code 4 are:

  • Renaming a file to a name of already existing file.
  • Creating a directory that already exists.
  • Moving a remote file to a different filesystem (HDD).
  • Uploading a file to a full filesystem (HDD).
  • Exceeding a user disk quota.

I can copy/delete/edit/add files though the built in manager to the root minecraft directory.

Here is the strange part, I can go an any subdirectory via login, like:
and I get in just fine though SFTP… it’s on the root directory that throws that error and only after it’s restarted.

Steps to reproduce:

  • Removed Instance
  • Setup New Fabric Instance
  • Configured Memory and server/started and allowed to finished setup and idle, then stopped
  • Connected using the “Connect to ftp link” on root minecraft directory… no problems
  • copied up mods, config and default config directories… nothing else…
    *stopped instance
    *started Instance
    *managed server and started minecraft fabric server
  • connected with client, broke a few blocks, closed world, shutdown server from console
  • Chose file manager from console (root directory) and used link…
  • Same error as above.
    *choose file manger and went to mod folder and had no issues, chose config folder, no issues… but I have root is a no go.
  • Since I’m admin I logged into the root of the AMP server (not in an instance)… navigated to the server/minecraft directory and got the same error… all other directories are accessible

Actions taken to resolve so far:

  • Installed another instance of fabric server. can access Minecraft directory. Added mods and configs only. Started minecraft server. Can’t access minecraft directory via sftp. All other directories respond (url with /directory works).

If you stop the Minecraft server, are you able to access the files?

No. Server up or down still no access. Where are the files located on the system. I can try and access the directory with root. NM. There in a docker container which I don’t think is directly mounted (I have no clue though, so…).

Don’t use root - you’ll immediately destroy your setup. Use the amp user instead. They’re located in ~/.ampdata.

Gotcha. Going to see what things look like in bash.

EDIT: Didn’t think I’d have a problem access the directory in the shell. No problems. Just can’t access the root of that instance (minecraft directory) once I make any changes to it. I can access any other directory via SFTP…