Bash errors when updating games

OS Name/Version: Debian 12

Product Name/Version: (Always use the full version number - not ‘Latest’)
[Info] AMP Instance Manager v2.5.0.4 built 04/04/2024 18:29

Problem Description:

tid(430) burning pthread_key_t == 0 so we never use it
Redirecting stderr to '/home/amp/Steam/logs/stderr.txt'
Logging directory: '/home/amp/Steam/logs'
minidumps folder is set to /tmp/dumps
[ 0%] Checking for available updates...
[----] Verifying installation...
UpdateUI: skip show logoSteam Console Client (c) Valve Corporation - version 1709846822
-- type 'quit' to exit --
Loading Steam API...OK
force_install_dir "896660"
Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
app_update 896660 -beta public validate
Update state (0x5) verifying install, progress: 0.38 (5242880 / 1396527811)
Update state (0x5) verifying install, progress: 43.50 (607546638 / 1396527811)
Update state (0x5) verifying install, progress: 89.12 (1244543350 / 1396527811)
Success! App '896660' fully installed.
mv: cannot stat '/AMP/Valheim/896660//Data/': No such file or directory
cp: cannot stat './Valheim/896660/BepInExPack_Valheim/*': No such file or directory```
  CubeCoders AMP  💻amp@machine  📁~  ampinstmgr --ValidateInstance BeeheimisHappy01
[Info] AMP Instance Manager v2.5.0.4 built 04/04/2024 18:29
[Info] Stream: Mainline / Release - built by CUBECODERS/buildbot on CCL-DEV
[Error] Unable to validate BeeheimisHappy01 - Download cache for 2504 does not exist.

Steps to reproduce:

  • Create new instance
  • Update Instance
  • Sad Trombone

Actions taken to resolve so far:

  • Validate: fails to validate, cries about missing cache
  • Delete instance and create new: same problem
  • Reboot: Have to manually start ADS01, and does not help
  • Reinstall: This error began occurring 72 hours into this installation, overnight.
  • sudo chown -R amp:amp /home/amp
  • Updated amp from command line, then ran ampinstmgr upgradeall
  • Swapped off of running in docker container
  • Update Instances from web panel

Update your instances from the main instances screen

That was one of the first things I tried. It’s not listed because it’s the same operation as ampinstmgr upgradeall, just manual.

It’s actually not - ampinstmgr can’t upgrade generic config templates. ADS can.

Ah, I stand corrected, I was under the impression that it was the same process. Ran it again, just in case this morning, and no change. Luckily though, the update didn’t break, and I am at least at a point where I can start the instance. Still get the same errors though.

Thunderstore has changed the BepInEx download URL. Will be updated shortly.

Awesome, thank you Greelan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.