Backups Failing after Latest Update (No Errors)

OS Name/Version: Ubuntu 20.04

Product Name/Version: v2.4.0.8, built 10/10/2022 21:18

Problem Description:
After the latest updates are not working, I once got a quick error that S3 wasn’t set up but it went away to fast for me to record it. There are no errors in the console and none when I request an update. The update just fails and does nothing. I checked the S3 to make sure its off but it almost seems like its still trying to use that.

The backup is blank: I know it’s trying because Backups.json gets updated.

Backup folder:

Cloud Backup Settings:

Local Backup Settings:

Empty your browser cache.

The same thing, cleared the cache and opened it in incognito. Fils with no error.

So what happens immediately after clicking “Create Backup”?

It acts like it tries, but then just goes away.

Stop AMP, delete your backups.json file, restart AMP, try taking a new one.

Did that and still no luck, same issue.

What browser etc are you using? I can’t reproduce this issue at all, nor the issue you’re getting with extra rows showing up. Can you also show me what your file manager looks like?

I am using chrome, i tried in both normal mode and incognito. I just tried in edge and it failed there too.

I did see this in the chrome console when trying the last update, i don’t know if its related.

Removing task 28de88f7-9951-4b61-aee8-e88377ffd1ce - Explicit Removal | UI.js?v= 
Removing task 9e4c37fb-8b68-44da-9ef7-5c9128c61a15 - No longer in remote store

This is the instances file manager:


So after deleting the backups.json - your backups list for that instance should now be empty?

The first time it did it cleared everything. I added some for testing so ill delete everything again to start fresh again.

Also, strangely, each of the failed backups shows up but only at 548B

I have deleted everything again and this time it did not in fact remove from the backups page. The files are gone but its still showing up on the backups page.

Turn on full debug logging, something is messed up somewhere:

Okay, updated the logging level. The backups disappeared after the restart, tried to take a backup and got this:

I have S3 turned off as seen in the previous posts so I’m not sure what’s going on there.

Here is the console output

Failure to make API call to BoostersOriginal01 ( - retried 10 times : Connection refused
[0] (HttpRequestException) : Connection refused
at ADSModule.WebMethods.MakeInstanceRequest (m.Http.IHttpRequest request, String REQ_RAWJSON, String requesturi) at ADSModule.WebMethods.Servers (m.Http.IHttpRequest request, String id, String REQ_RAWJSON)
[1] (SocketException) : Connection refused
AMP instance BoostersOriginal01 is now running.
Managed remote instance BoostersOriginal01 at
Authentication token for admin requested by ManageInstance on behalf of admin
Creating Backup: test
Missing plugin/assembly: log4net (/home/amp/.ampdata/instances/ADS/Plugins/log4net/log4net.dll) for

That’s the log from ADS, not the instance you’re trying to work with.

My apologies, the only thing in the instance’s console is Minecraft information:

[dynmap]: Loaded 2 maps of world 'world_nether'.
[dynmap]: Loaded 2 maps of world 'world_the_end'.
[dynmap]: Enabled
[ForestPlant]: Enabling ForestPlant vv1.0.3
[ForestPlant]: INFO : Using lang 'en'
[ForestPlant]: INFO : messages_en.yml loaded successfully!
[SuperVanish]: Enabling SuperVanish v6.2.12
[SuperVanish]: Please install ProtocolLib to be able to use all SuperVanish features:
[SuperVanish]: Hooked into dynmap
[floodgate]: Enabling floodgate v2.2.0-SNAPSHOT (b73-4f36112)
[ArmoredElytra]: Enabling ArmoredElytra v2.4.15
[ArmoredElytra]: Enabling stats! Thanks, it really helps!
[ArmoredElytra]: Durability penalty for flying enabled!
[ArmoredElytra]: Allowed enchantments:
[ArmoredElytra]: - DURABILITY
[ArmoredElytra]: - PROTECTION_FIRE
[ArmoredElytra]: - THORNS
[ArmoredElytra]: - BINDING_CURSE
[ArmoredElytra]: - VANISHING_CURSE
[ArmoredElytra]: - MENDING
[SetHomes]: Enabling SetHomes v1.3.0
[SetHomes]: Hooked into LuckPerms!
[Geyser-Spigot]: Enabling Geyser-Spigot v2.1.0-SNAPSHOT
[Geyser-Spigot]: ******************************************
[Geyser-Spigot]: Loading Geyser version 2.1.0-SNAPSHOT (git-master-a84362a)
[Geyser-Spigot]: ******************************************
[Geyser-Spigot]: Started Geyser on
[Geyser-Spigot]: Done (2.314s)! Run /geyser help for help!
Running delayed init tasks
Done (11.627s)! For help, type "help"
Timings Reset
Saving the game (this may take a moment!)
Saved the game
Automatic saving is now disabled
Automatic saving is now enabled

It’s not in the console. It’s in the log files. Right click → view logs on the instance.

Hey! I didn’t know that, wow that’s really helpful information.

Here’s the log file:

[16:39:06] [FileBackup:admin Activity] : Creating Backup: test2
[16:39:06] [FileBackup:admin Debug] : Building file list...
[16:39:06] [FileBackup:admin Debug] : Found backup exclusion file: /home/amp/.ampdata/instances/BoostersOriginal01/Minecraft/.backupExclude
[16:39:06] [FileBackup:admin Debug] : Added 0 exclusions
[16:39:06] [FileBackup:admin Debug] : Skipping /home/amp/.ampdata/instances/BoostersOriginal01/Minecraft/ (Empty .backupExclude in root)
[16:39:06] [FileBackup:admin Debug] : File list built: 0 files totaling 0MB
[16:39:06] [FileBackup:admin Debug] : Checking cycling requirements...
[16:39:06] [FileBackup:admin Debug] : Adding files to archive...
[16:39:06] [FileBackup:admin Debug] : Saving archive...
[12:39:06] [INFO]: Saving the game (this may take a moment!)
[16:39:06] [FileBackup:admin Debug] : Backup complete.
[12:39:06] [INFO]: Saved the game
[12:39:06] [INFO]: Automatic saving is now disabled
[12:39:06] [INFO]: Automatic saving is now enabled

It was too big to upload here so here’s the full file:

Delete the .backupExclude file.

That seems to have worked, thank you.