Backup deletion issue

OS Name/Version: Ubuntu 22.04

Product Name/Version: Amp v2.4.0.8

Problem Description: AMP is not automatically deleting backups, even though it is set to do so. I had an issue recently where it was unable to, due to permissions settings, but those have been fixed until I updated AMP today. Now it is saying that I’ve reached the backup limit, and to delete backups in order to make new ones. However, my backup limit is set to 5, and my Backup Replacement Policy is set to Delete Single Oldest, so it should be deleting the oldest backup and making a new one, as it has always done in the past. This also happens when I attempt to create a manual backup, I get the same error, that I’ve reached the backup limit, when before it always just deleted the oldest backup for me and made a new one.

Steps to reproduce:

  • Set backup limit to a number and set Replacement Policy to “Delete Single Oldest”
  • Make backups until hitting the limit
  • Receive error code

Actions taken to resolve so far: Unsure if I could do much to resolve this, open to suggestions. Thank you.

If deleting the single oldest backup wouldn’t free up enough space, then it won’t do anything. If you want it to delete as many as necessary, pick “Keep Deleting” as the policy.

I have the same problem:

Settings are as always, worked until 10/11, then backup stopped working. I didnt change any settings. I have enough space left, only 12 % of space used.


Where do I find the “Keep Deleting” option? I only have these 3 for choice:


What did I do wrong?

I also cannot make a manual backup at all. When I start a manual Backup it sais:

Ah sorry, it’s “Delete Multiple” not “Keep Deleting” (that was the old name)

I think that´s not the solution. As you can see, I have 165 GB free space, that´s a) enough for a backup and b) would only happen, if the new backup would be larger than an old one, and deleting the old one, wouldnt free up enough space. pls look at my screenshots, I have enough space for another backup.

Anyway…I tested with Delete Multiple…no chance…the only thing that works is to increase the counter. For me there´s an issue with deleting old backups that came with the new update! Maybe the new cloud backup function?

@Skorpeyon increase your backup limit, delete old backups by hand, and wait for a fix.

@Mike Thx for your help

problem not solved yet :frowning:

I can now backup again, increasing the limit…but delete single oldest now deletes the newest file :frowning:

I just made a backup by hand and as you can see by the time, 9:41 it deleted the backup taken this night at 4:00

What I recognized too, is that the filesize does not match anymore

I deleted backup.json file to test.

Any update on this? mine just started doing this after update

I’m having the same issue, and can confirm it’s not global size being reached.

My backups are all set to “Delete multiple” (I got hit by the first-backup-is-smaller got’cha a while ago). Also, manually removing backups from the directory and creating a manual backup leads to a “Backup already in progress” error:

This event doesn’t seem to get written to the logs at all, so it looks like it’s handled on the front-end.

My last successful backup, on any instance, was 4am on the 11th of this month, when AMP went offline for its weekly storage-level backup.

As it stands now, no instance has a valid backup, or can take a valid backup. Even a newly-created one.

I think I’m having this issue too, also I don’t seem to be able to manually delete backups. Can I check if anyone else has that issue too - as these may be related?

Did you specify a different location than the default for your backups, by any chance?

I’ve just checked, and if I delete the LocalFileBackupPlugin.Storage.StorePath value I had set, and create a new instance, I have a delete button again, and the backups show as being in a local datastore:

vs my other, unchanged, instance: (note the unlit icon on the right)

I’m attempting to add my custom backup location as a datastore now, but AMP won’t let you add a non-empty directory, so it’ll take a minute. Will report back.

Edit: Manually creating the datastore for the custom location, moving backups back into it, and restarting instances doesn’t appear to fix the issue. Newly created instances are showing correctly now however.

Edit2: After deleting my Backups.json file in the backup dir for my test instance, the backups seem to be being created and deleted according to settings.

No, I didn’t change the backups location. But your suggestions seem encouraging!

I am also on v2.4.0.8 and have started having backup issues since updating.

On one of my instances I deleted the Backups.json file and that allowed my automated backups to proceed as normal, however it is still throwing an error about uploading to S3 even though I do not have cloud backups configured or enabled.

I’ve changed the S3 upload mode to Manual Only to see if that makes any difference.

I realize it’s been two weeks since I posted this. I honestly haven’t had time to sit and figure it out, but it does look like this is, or was, an error in the program? I will say, AMP did something that ate up all of my harddrive space. I only have a 53GB hard drive, but was storing all of my backups externally on a 2TB one. There was no way I didn’t have space for a backup, AMP was just acting as though I didn’t for some reason, and not deleting old files. The only way it might not have had space was by hitting the limit I had set, and deleting one backup would’ve left plenty of room for a new one.

Today I decided to return to this and completely uninstalled, removed the amp user folder, and suddenly freed up 75% of my primary hard drive. So AMP was taking up around 35GB of space for a single Minecraft instance with a world that was less than 10GB. Not sure if this was some kind of issue where every time it failed to back up it didn’t remove temporary files, or what, but I’ve been struggling with this hard drive space issue for the past couple of weeks and only now realized that AMP was somehow the cause. Trying with a fresh install to see if that can fix things.

EDIT: Having reinstalled AMP, I’ve been able to take manual backups, which I wasn’t able to do before. However, the scheduled backup I tried last night, at 3AM, did not work, so I’ve followed the advice from Daedalus and deleted the backups.json file on my install (I’d restored it from the broken install along with the backups, because I couldn’t find a way to restore an external backup from within AMP, which seems like an oversight to me). This did not fix my problem, mine still will not take a scheduled backup. I just set one for a minute ago, and nothing happened. I can at least now manually take backups, but I cannot do so automatically for some reason. A step in the right direction, I suppose. Still not sure how to fix the automatic backups, however.

Would like to note that I had also specified a different location than the default for my backups, so perhaps that does have something to do with why this is happening to people?

EDIT 2: Apparently, even though all the timestamps in the console and on files are correct, I noticed in the log that AMP thinks it is 4 hours in the future, so I’d set the time wrong on my automatic backup. This also explains why it hadn’t backed up last night, as I set it for 3AM every, but it was already midnight. So AMP thought it was already 4AM, so to it 3AM had already passed. Just ran a successful automatic backup.

Also wanted to note that I also have the same “double size” issue on backups that others mentioned. I believe it’s an issue with the Backups.json? I think it’s writing the size before being compressed, rather than after. But the compression is still taking place, as looking in the backups folder, I can confirm the file size is the same as it was before reinstalling. For me, this was initially only happening on manual backups, but the scheduled backup I just took is also displaying as twice its actual size. Attaching images for reference. This doesn’t bother me as much as the not being able to take backups, but I do wonder if it’ll cause problems with the storage limits for backups, and if maybe that caused my initial issues?

For me the most recent update fixed all of my issues…

Before the update all of my backups weren’t being labeled as stored locally, couldn’t delete them and couldn’t take a back up…

NEW instances were working fine tho, i had tested that. after the most recent update… everything is working as normal and tail back ups are being deleted properly.

Idk. But thanks to the team for whatever fixed it XD