Automatic Steam Updates not working on Windows Server

OS Name/Version: Windows 10

Product Name/Version: Decadeus v2.4.3

Problem Description: Hi all,
I have been trying for some time to get two of my instances to do auto updates(I only have two), a Icarus and Satisfactory server. I have followed some steps after I reached out to CubeCoders on youtube and the instructions I received dont appear to work. Here are the instructions and what my settings are. Have I done something wrong?

  1. Create a ‘Time’ trigger to run when you want AMP to check for updates. For example every 6 hours or every day at 3AM say. 2) Add a “Check for available updates via SteamCMD” task to that trigger. 3) Create a ‘Event’ trigger to run when “An update is available via SteamCMD” 4) Add a “Update the application and restart it if it was previously running” task to that trigger.

Actions taken to resolve so far: Tried different combinations and no change.

Check AMPs logs at the point it does the update. Does it say that the manifest versions are different?

Thanks for the reply Mike, I will post back here on Friday when the next icarus update comes out.

had similar issue that i fixed installing

Thanks for the advice Junior, I will report back when the next update occurs. :slight_smile:

Im haveing a similar issue on ubuntu 20.4 and windows 10 instances.

i have a trigger set to scan for a new version via steamCMD every minute then another trigger that simply schedules an update and restart once the last player leave or if empty if an update is available.

Currently this is happening with all my hosted games. To name a few;

  • Valheim
  • Dont starve together
  • Space engineers
  • Core Keeper
  • Avorion
  • Project Zomboid

If i force the triggers to start now for checking every minute if there is an update the game does not update and restart

if i force the trigger for schedule and update and restart one the last player leaves etc the game does stop and update - whats the issue with those two triggers talking to eachother?

Also i could not see any errors about manifest versions being different

Thanks TheGreenWheel
Icarus had two updates this week, I tried both settings for steam updates BuildID or Timestamp both did not work.

I also did the same as you, manually running the Check for available updates via SteamCMD with the trigger setup as per the screen shot and it does nothing. But manually pressing the Schedule an update and restart once the last user leaves, or immediately if empty updates as expected.

Here is the manifest if its any help
“appid” “2089300”
“Universe” “1”
“LauncherPath” “E:\AMPDatastore\Instances\Icarus01\icarus\steamcmd.exe”
“name” “Icarus Dedicated Server”
“StateFlags” “4”
“installdir” “Icarus Dedicated Server”
“LastUpdated” “1682048725”
“SizeOnDisk” “12860617954”
“StagingSize” “0”
“buildid” “11047143”
“LastOwner” “76561201269272873”
“UpdateResult” “0”
“BytesToDownload” “389035760”
“BytesDownloaded” “389035760”
“BytesToStage” “11714729491”
“BytesStaged” “11714729491”
“TargetBuildID” “11047143”
“AutoUpdateBehavior” “0”
“AllowOtherDownloadsWhileRunning” “0”
“ScheduledAutoUpdate” “0”
“manifest” “1877119354817218948”
“size” “12860617954”

I think the bug where steamcmd doesn’t show you the current manifest properly is rearing it’s head. I’ll have to figure something else out.

Thanks Mike, appreciate any help you can give :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.