Application Deployment - My admin password wont work in game as server admin

System Information

Field Value
Operating System Linux - Debian GNU/Linux 11 on x86_64
Product AMP ‘Decadeus’ v2.4.8.0 (Mainline)
Virtualization QEMU_KVM
Application Application Deployment
Module ADSModule
Running in Container No
Current State Indeterminate

Task

admin password

Problem Description

Issue

I changed it and used generated password and restarted server and still wont work.

Reproduction Steps

  • Changed password, used generated password, and reset server
  • Changed password to a generated password in the server configuration
  • Reset the server after changing password and generated password in configuration

Your explanation is light on details - I have no idea what password you’re actually talking about. Is this the password for AMP itself, or some game server within it?

If this is for Palworld, I have similar issues, but I think this is a combination of both AMP and a gameserver software issue.

On AMP side, it uses the RCON password for the server admin password, which is a PITA to change because it requires HTTPS to do it through the web interface (which I don’t have set up because its a private in-house server).

And, even if you set it to not randomly generate a passworld and manually change it in the config, on instance/game server startup in changes it back to what was saved/generated before.

On the game server software side, even if you copy the RCON password and paste it in-game, it still states incorrect password, which leads me to believe it is a bug in the server software itself (probably cant handle that long of a string for an admin password).

You have to change it to a shorter password. AMP’s default is too long for the in-game chat, which is limited to ~30 characters (fml). Unfortunately, I can’t change how AMP generates the default