Amp won't open on my system

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Windows 10

Product Name/Version: I can’t find my version anywhere as I can’t access the application

Problem Description: I have AMP installed on my remote server, but every time I try to open the launcher, it uses my browser to error out and says “This site can’t be reached”. I have tried opening my ports and everything, but when I install it on my actual PC account, it works just fine. What am I doing wrong here??? The program worked fine on my remote server desktop until the most recent update to Windows, but I needed that update to run my other gaming servers I have going.

Actions taken to resolve so far: I have tried opening inbound and outbound rules on my firewall to allow access, but that isn’t resolving the issue. I have tried deleting all files and reinstalling, no change. I am at a loss after my company spent $40 on the Advanced Edition of AMP.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.