AMP Web UI not loading

OS Name/Version:Ubuntu 20.04

Product Name/Version: AMP latest version (I can’t actually identify the version however as the web UI doesn’t load it was only installed last night so it should be the latest if there is a way of finding this within Linux let me know and ill get it).

Problem Description:

Hey Everyone,

When I attempt to load the AMP web Ui it doesn’t load and eventually, times out see below screenshot.

I have tried restarting the VM and clearing my cache and using incognito in chrome neither of these has worked.


Edit: It’s also worth noting the web UI has worked before.

Check if AMP is running. You can do this from your admin user by running:

sudo su -l amp -c "ampinstmgr status"

Hey Mike,

Thanks for the reply.

Looks like it is running from this output however the web GUI still doesn’t seem to load.

tomas@amp-01:~$ sudo su -l amp -c “ampinstmgr status”
[Info] AMP Instance Manager v2.3.2.10 built 21/04/2022 15:10
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance Name │ Friendly Name │ Module │ IP │ Port │ Up
ADS01 │ ADS01 │ ADS │ │ 8080 │ ✓
redatcted │ mc.layer9.sys… │ Minecraft │ │ 8081 │ ✓
redacted │ satisfactory… │ Generic │ │ 8082 │ ✓

8081 and 8082 just report connection refused.

Its also worth noting before AMP was installed this was a fresh ubuntu install with no firewall.

Edit: I’ve also taken a look and found that AMP does appear to be listening on 8080
AMP_Linux 44359 amp 16u IPv4 519429 0t0 TCP *:8080 (LISTEN)


If AMP is listening then it’s probably a firewall issue. Check that the system firewall rules allow port 8080 TCP.

Also check that you’ve not inadvertently switched firewalls, e.g. Between UFW and IP Tables.

Hi Mike,

Thanks for that looks like IPtables had turned itself on during an update.

Much appreciated sorry for wasting your time.