Amp upgrade to breaks file manager

OS Name/Version: Debian 12

Product Name/Version: AMP Release “Decadeus” v2.4.5.4

Problem Description:

After updating from v2.4.5.2 to v2.4.5.4 File Manager is no longer showing any files or folders under the initial folders. It was working normally before the upgrade.

Steps to reproduce: Upgrade to AMP v2.4.5.4 from v2.4.5.2

Steps taken so far:

Step 1: Rebooted server
Step 2: Reinstalled AMP
Step 3: Reinstalled OS and AMP v2.4.5.4 without upgrade.

Have you emptied your browser cache?

Can you press F12 to bring up the developer console and go to File Manager again. Then screenshot any errors you see?

I was coming here to check on exactly this issue, saw your post, and decided to give that a shot. I had already cleared my cache as suggested above and that didn’t help. The error that came up when clicking any folder in the File Manager is:

VM4020:839 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'getTimestamp')
    at new fileEntryVM (eval at scriptLoaded (PluginHandler.js?v=, <anonymous>:839:46)
    at fileListVM.refresh (eval at scriptLoaded (PluginHandler.js?v=, <anonymous>:1202:26)

Just tried clearing browser cache and no difference. I also tried another browser altogether. Folders are still empty.

I am glad I found this. I was losing my mind thinking I had done something wrong on my instance. I can still the files if I SFTP to the server but not through the browser. not sure if this has anything to do with it or not but when I did some troubleshooting and re-upgraded my instance I got this error
Can't find custom attr constructor image: /opt/cubecoders/amp/plugins/ADSModule.dll mtoken: 0x0a00001e due to: Could not load file or assembly 'SQLite-net, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

Can confirm, everything was working fine before upgrading, now File Manager no longer shows any files at all, sftp doesnt work, normal root access via scp does. Tried clearing browser cache, as well as using Incognito, no changes. Manually reinstalling Amp works fine again.

I think Mike has a fix put in for the next release. He hasn’t commented yet, just going by the commit today.

A patch has been shipped that fixes this. Not all systems were affected which is why it didn’t show up. If you’re already on you should get a notification that a new patch is available.

Just installed the patch, it does appear to have fixed the issue for me.

Installed the patch and file manager is back to normal.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.