AMP 'Triton' Release Notes

OK, so you are saying the unzipping is not happening. Anything in the logs for the instance? May be a bug in AMP

I will try to delete the instance and start over again. Give you a step by step of what is not working.

I created a new xonotic instance. Then it does what I wrote above:


Let me test at my end. Something may have been broken in AMP. The template is configured properly but AMP may be failing to unzip

[14:00:52] [Core Info]            : Starting AMP version (Triton), built 16/06/2022 16:08
[14:00:52] [Core Info]            : Stream: Mainline (Release) - built by CUBECODERS/buildbot on CCL-DEV
[14:00:52] [Core Info]            : Running in a QEMU KVM environment.
[14:00:53] [Core Info]            : Checking for AMP updates...
[14:00:54] [Core Info]            : AMP is up-to-date.
[14:01:24] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user admin from
[14:01:24] [RemoteAMPAuth:Anonymous Activity] : Authentication success
[14:02:06] [API:admin Activity]   : Starting the application.
[14:02:06] [Generic:admin Info]   : Specified executable '/home/amp/.ampdata/instances/FAFXON/xonotic/Xonotic/xonotic-linux64-dedicated does not exist. Updating application...
[14:02:49] [Generic:admin Info]   : Extracting to ./xonotic/./...

Then nothing…

That looks to me like you are hitting Start before you hit Update?

After creating an instance, hit Update first to install the server, then hit Start

Did both, will try again. Fresh start again.

Same error on just pushing the “update”. I will test it out later on, and maybe try a new AMP build just for this. I have a Xonotic-server KVM just in case, so it is not an issue for me right now, just wanted to test it in AMP.

If it works for you, I’m sure it works for others too.

Thank you for your time.

Same for me. Seems something is broken with the unzipping. Let me try autobuild

Autobuild does not work too.

Yep. Mike’s broken something lol

That explains it… :slight_smile: Thank you.

I’ve submitted a bug report: Generic unzip in FetchURL update stage not working · Issue #660 · CubeCoders/AMP · GitHub

Thank you. I run autobuild btw. Looking forward to experiencing a working Xonotic in AMP. So excited. Thank you for the help.

This is now fixed in the latest nightly build. Set the release stream under new instance defaults to Nightly, then create a new instance.

When the next AMP mainline release comes out you can switch the instance back to mainline with ampinstmgr switch.

Will test. Thank you very much for the help :slight_smile: