AMP stopped working after updating Linux

OS Name/Version: Debian 12 Bullseye

Product Name/Version: Not sure. I last updated on July 1st, 2023.

Problem Description: After updating to Debian 12 I cannot connect to the web interface for AMP. I have a Debian 11 backup I could go back to. Was wondering if anyone knows about this issue? Also when I tried to use the “ampinstmgr” command on the amp user it says “segmentation fault”.

Steps to reproduce:

Turn on Linux Machine
Tries to connect via IP:8080
Says “This site can’t be reached”

Actions taken to resolve so far: Tried restarting the OS, updating the OS, tried using the ampinstmgr command with an error of “segmentation fault”

Update: I tried reverting back to a previous backup on Debian 11. This backup AMP was still working and it still says segmentation fault when I used the “ampinstmgr”. I also have tried reinstalling the “ampinstmgr” package.

Check your repositories - after updating Debian, third party repos will likely have been disabled.

Re-enable the CubeCoders repo and check for updates.

They seem to be enabled. I don’t think Docker was updated to the Bullseye version. Do you think that could do it?

These are the current repositories I see when I do “apt update”

Hit:1 Index of linux/debian/ bookworm InRelease
Hit:2 Index of /debian bookworm InRelease
Hit:3 Index of /debian bookworm-updates InRelease
Hit:4 bookworm-security InRelease
Hit:5 Index of /webupd8team/java/ubuntu xenial InRelease
Hit:6 debian/ InRelease

@Jace_B What kernel version are you running, and when you restored from backup did your kernel stay the same? I believe Debian 12 updates you to 6.1.

I’ve updated today and my kernel went from 5.15 to 6.2 and I’ve ran into the same problem with the segmentation fault in ampinstmgr.

ampinstmgr.service: Main process exited, code=killed, status=11/SEGV
ampinstmgr.service: Failed with result 'signal'.

I’m running the very latest version of AMP, patches and all.

[Info] AMP Instance Manager v2.4.5.4 built 26/06/2023 18:20

As soon as I pinned the old kernel and rebooted it started up again.
Guessing there’s a breaking change in one of those kernels between 5.15 and 6.2.

I am currently on 6.2 it looks like

It’s interesting that with fresh Debian 12 installs, it seems to work fine. Only with upgrades from Debian 11 to 12 does this segfault issue seem to occur

I’ve just tested and the issue only happens with kernel 6.2 (and above, presumably).

6.1 works fine, so that’s why people running Debian 12 out of the box aren’t seeing issues, as it bundles that version.

Not a big deal for me personally as I’ll just pin 6.1 for now, but I’d imagine a number of people will run into this issue over the coming days and weeks as they run updates

I already did the upgrade from Debian 11 to Debian 12 and I’m also on Kernel 6.2 but I haven’t encountered any problems

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.