Amp server running on linux server, unable to access web gui

thank you for the help none the less :frowning:

You can’t run fixperms as the amp user, need to be root

I’d also run as root systemctl restart ampinstmgr


its sudo systemctl restart ampinstmgr

Show output of sudo systemctl status ampinstmgr

it was very long x@zero:~$ sudo systemctl status ampinstmgr[sudo] password for x:× ampinstmgr -

Weird stuff. Try this:

sudo su -l amp
ampinstmgr stopall
ampinstmgr --nocache upgradeall
ampinstmgr start ADS

 CubeCoders AMP  💻amp@zero  📁~  ampinstmgr stopallUnhandled Exception: - , same error every time

Did you ever run the fixperms command as root?

If not, exit the amp user shell to get back to the normal user.

Then sudo su -l to switch to root

Then ampinstmgr fixperms

No error? Possible progress? i ran it as root earlier but it didn’t work. this time it did
Still no web interface tho

Did you restart AMP?

su -l amp -c "ampinstmgr start ADS"

Ah, what does df -h show?

In particular, is your root partition full?

Possibly? alittle odd considering its 120gb ssd

Yeah, rip you are full.

By default Ubuntu doesn’t take up the whole disk free space with the root logical volume unless you tell it to.

You will need to look into expanding the root logical volume and it’s file system to give you more space. Will be plenty of instructions on Google.

Note that your AMP install may have been borked regardless because of the space issue.


r…iii…ppp, hope there is a chance that’ll fix with a volume extend

You can also delete the old AMP cached downloads in /home/amp/.ampdata/instances to free up some space

ayyyyyyyyyyyyyyyyyyeeeeee , Thanks so much for the help man!!