AMP, Server 2022 Core, Proxy, SFTP

OS Name/Version: Windows Server 2022 Standard Core

Product Name/Version: (Always use the full version number - not ‘Latest’)

Problem Description: Installed on server 2022 core. Noticed there is no LetsEncrypt or secure HTTPS after install. Decided to leverage HAProxy and CloudFlare to protect AMP Panel. After setup the panel appears to be working fine.

SFTP does not work because it points to Cloudflare (HTTPS only). Tried to use the option in AMP configuration to specify a base url to host records that are setup for the direct IP. I guess I don’t understand what the base url configuration option is as it didn’t solve my problem.

Is there some configurations change I can make so that SFTP uses a different A record for connections? I want to keep my panel secured by proxy while still allowing SFTP direct to the server.

Afaik the base url is not working atm. Think there is a bug report on GitHub.

Also note that proxying through Cloudflare will cause caching issues after an amp update. You will need to manually clear the Cloudflare cache each time.

Is there a suggested alternative to CloudFlare for a Proxy?

Or a way to turn off caching in amp/cloudflare

Actually, see here re base url: Connect to SFTP popup on target shows incorrect full address/host · Issue #760 · CubeCoders/AMP · GitHub

If you are proxying traffic through Cloudflare, it caches. That’s the point of a CDN. Grey cloud the DNS to avoid proxying.

I need CloudFlare to provide some level of protection to the panel. I was able to create a cache bypass rule in Cloudflare for the panels address.

Hmmm. I recreated my instance, and it errors out as: ReferenceError: URI is not defined for the SFTP URI. I assume this is related to the bug and that I’ll have to wait for the next release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.