AMP new install - Can't access web interface from browser

OS Name/Version: Canonical Ubuntu 22.04 (Oracle Cloud aarch64)

Product Name/Version: AMP v2.4.6

Problem Description:


I’m very new to working on a server, using SSH, and am trying to setup a Minecraft Bedrock server as a personal project. I installed AMP because I thought it would be a nice way to have a web interface that I can manage the server from anywhere.

For the life of me I can’t connect to the AMP interface using my browser; going to the server’s IP address, both the address AMP gives me for the running instance and the server’s IP address with the appropriate port specified, results in the browser loading until it says that the server took too long to respond. Can someone help me out here?

I can’t provide any logs because my SFTP client in MobaXterm says I don’t have permission to access the home/amp directory.

Steps to reproduce:

  • Step 1: Installed AMP by running command
bash <(wget -qO-

as root. Used custom username and password for login details. Skipped enabling HTTPS, but chose yes for installing Java and yes for CP Aarch64 compatibility tool.

  • Step 2 : Followed all steps in this tutorial, including Step 5 and also adding ingress rules for ports 8080, 443, and 25565 in Oracle dashboard

“Using AMP on Oracle Cloud” :

  • Step 3: Made sure AMP instance was running

  • Step 4: Attempted to connect to server using

External IP Address :8080
and also attempted using IP address given by starting AMP instance

in Google Chrome web browser.

Actions taken to resolve so far:

  • Started, stopped, deleted, and recreated AMP instance multiple times (had to buy and use a license key to create instances using ampinstmgr)
  • Attempted to uninstall and reinstall AMP by running apt remove ampinstmgr, and trying to install again. Got same result.

UPDATE: I managed to change permissions on the amp folder to chmod 775 and will upload the logs here for the instance

[link removed]

Update 2: FIXED IT MYSELF! Turns out I configured the Oracle VCN firewall ingress rules wrong. You’re supposed to leave the source port fields blank, and only put the ports you want to open for receiving in the destination port field. This web admin stuff feels very complicated and heavy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.