AMP lost it's licese key after system reboot

OS Name/Version: Debian GNU/Linux 11 (bullseye)

Product Name/Version: AMP Release “Halimede” v2.4.0.10

Problem Description:

So I have amp installed on my home server to run Minecraft instances. For energy savings it get’s shutdown at 0:00 and booted again at 8:00am. This has been working perfectly for months now. But as of (I believe then it started), every time the system is rebooted I get the message: “AMP has lost its licence key due to a hardware or system configuration change. Please re-enter your licence key under Configuration → New Instance Defaults. You may also need to reactivate your existing instances on this host.”

So then I need to re-enter the license and then Reactivate Local Instances or via cli “ampinstmgr reactivateall”. That works and re-activates the instances.

The hardware offcourse doesn’t change, also the macaddress stays the same.
All instances are running in docker containers. Amp is installed locally via the repo. (right now I am using 70/10 licenceses because of all the reboots I did, trying to solve the problem :cold_sweat: )

Steps to reproduce:

Just reboot the system.

Actions taken to resolve so far:

Upgraded all instances to latest version v2.4.0.10
I had openvpn running on the server before, but it had no influence, the setup was working even with openvpn active. I removed it just to make sure but it made no difference.

Is this a physical machine or a virtual machine that AMP is installed on? Does the system have any network adapters (virtual or physical) whose MAC address changes between reboots?

Hello Mike, it’s a physical machine. It has 2 physical network adapters, only one is connected and it has a static IP and a static MAC address. It doesn’t change between reboots. I run about 20 docker containers with different network configurations, bridge, host and macvlan. There are virtual interfaces, but they are all docker related. I do see that these virtual adapters change mac address after a reboot.

Is ampinstmg itself up-to-date? (run ampinstmgr version to check)

I’t running on

[Info] AMP Instance Manager v2.4.0.10 built 27/10/2022 18:16
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

What I do find odd is that when i run ‘ampinstmgr reactivateall’ I see 2.4.04 zipping by.

[Info] AMP Instance Manager v2.4.0.10 built 27/10/2022 18:16
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] Checking licence key...
[Info] Licence Type:  AMP Professional
[Info] Current Usage: 85
[Info] Reactivating instance ForgeTest...
[Info] Stopping instance ForgeTest01...
[Info] Instance ForgeTest01 has stopped.
[Info] [Info] AMPStart for Docker - v22.08.1
                                            [Info] [Info] Performing first-time container setup...
                                                                                                  [Info] [Info] Container setup complete.
                             [Info] [Info] AMP Instance Manager v2.4.0.4 built 10/09/2022 16:02
                                                                                               [Info] [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
                                                                [Info] [Info] Certificates have been synced.
                                                                                                           [Info] [10:37:51] [Core Info]            : Starting AMP version (Halimede), built 27/10/2022 18:15
                                                                                                          [Info] [10:37:51] [Core Info]            : Stream: Mainline (Release) - built by CUBECODERS/buildbot on CCL-DEV
 [Info] [10:37:52] [Core Info]            : Loading configuration from provisionargs.kvp...

However whe i do ‘ampinstmgr -i ForgeTest’ it then shows:

[Info] AMP Instance Manager v2.4.0.10 built 27/10/2022 18:16
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
Instance ID        │ eb9c16b5-efb7-4d37-9a92-92b710aee6a4
Module             │ Minecraft
Instance Name      │ ForgeTest01
Friendly Name      │ ForgeTest
URL                │
Running            │ Yes
Runs in Container  │ Yes
Runs as Shared     │ No
Start on Boot      │ No
AMP Version        │
Release Stream     │ Mainline
Data Path          │ /home/amp/.ampdata/instances/ForgeTest01

Don’t know if that is normal?

I have the exact same problem. Since the last update, all my instances are losing their license key after every reboot.

Is there any news on this issue?

I also have problem, im running AMP in docker on unraid. When i do any network changes i loose my license. i have now used 5/5 but i only running one server!

and last time everything on that server was lost(minecraft) Must be a better way to bind the license then to the MAC-address!

You are running an unsupported setup. You need to run amp in a vm on unraid

You know of any plans to support dockers?

Not going to happen. Docker is too limiting for AMP to do its job properly. You couldn’t even add new network ports without shutting the entire thing down. Run AMP in a proper VM and let it manage containers.