AMP Arma 3 workshop download problems

OS Name/Version: Ubuntu 22.04.1 LTS Server

Product Name/Version: AMP

Problem Description:

SteamCMD Workshop downloader crashes, AMP is stuck on SteamCMD download step 1/6,
It will download about half of the mods / workshop items.
I’m trying to get 14 mods installed on the Arma 3 server instance.
SteamCMD downloads 5 items at a time, but seems like it will start a new CMD session for every 5 items, the first block is ok, at block 2 of 3 it stops, console output views nothing and the only way to retry is killing the instance.

Steps to reproduce:

  • Fresh Arma 3 Instance
  • Adding Workshop items in SteamCMD and Updates section in settings
  • Starting instance and updating.

Actions taken to resolve so far:
I have tried to add every ID separate and tried it as a collection of mods trough Steam.
AMP is still getting stuck in the download process.

It looks like this:
Downloading item 782415569 …
ERROR! Download item 782415569 failed (Failure).workshop_download_item 107410 2034363662 validate
Downloading item 2034363662 …
Success. Downloaded item 2034363662 to “/home/amp/.ampdata/instances/Arma301/arma3/233780/steamapps/workshop/content/107410/2034363662” (206431 bytes) workshop_download_item 107410 1374639840 validate
Downloading item 1374639840 …
Success. Downloaded item 1374639840 to “/home/amp/.ampdata/instances/Arma301/arma3/233780/steamapps/workshop/content/107410/1374639840” (343148 bytes) workshop_download_item 107410 1355481562 validate
Downloading item 1355481562 …
Success. Downloaded item 1355481562 to “/home/amp/.ampdata/instances/Arma301/arma3/233780/steamapps/workshop/content/107410/1355481562” (1075563 bytes) workshop_download_item 107410 766491311 validate
Downloading item 766491311 …
Success. Downloaded item 766491311 to “/home/amp/.ampdata/instances/Arma301/arma3/233780/steamapps/workshop/content/107410/766491311” (17153120 bytes) quit

from my Testing it seems to be ID 463939057 from the Workshop.
Downloaded the files manualy with SteamCMD and I’m getting error 4 from SFTP,
this file is getting error 4 “ace_javelin.pbo.ace_3.15.2.69-d1a631b1.bisign” no problems downloading from SteamCMD on my computer but the AMP server is getting error 4 when I transfer the files.

I also tested just adding this id to the SteamCMD part of the settings and just updating, seems like this addon is breaking the download in AMP but not if downloaded manually in the SteamCMD windows client.

Collection with all mods: Steam Workshop::Overthrow Sorsell IT

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.