After updating AMP I can no longer change between online-mode false and true

OS Name/Version: Windows 10 64-bit

Product Name/Version: v2.4.3, built 14/03/2023 23:15

Problem Description: After updating AMP, no matter what I do I cannot get online-mode to change to anything but true. I switch back and forth regularly for a variety of reasons and no longer can. Other changes to the files save, except this one. It is almost as if this specific string is being blocked now.

Actions taken to resolve so far: Tried editing in and outside of program. Tried importing, tried copying over from a backup. Tried changing the option in MinecraftModule.kvp to Minecraft.Offline=true.

Just a general note, online-mode=false is only supported for Proxy server setups.
As mentioned in the update notes, there is a new option under Server Settings called Standalone Server that now handles this.

1 Like

Ive disabled standalone on every instance connected to the proxy and its giving me issues still also.

Be sure to restart the Minecraft servers after updating the setting. I migrated ~20 servers with no issues.

1 Like

Thank you so much. You are a beautiful human being.

That worked for me right away without reboot. Thanks!

Since we have the Standalone Server off, the server doesn’t recognize that they are any players on the server even if they are in, and it’s go to sleep mode.

You need a proxy for Standalone Server=off to work properly.

Sleep mode and player tracking only works with online mode servers, or proxies that are fully configured to forward authentication information and the players UUID.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.