After Update to 2.5.00 Rust Server problem

OS Name/Version:
Debian Linux Bookworm

Product Name/Version: (Always use the full version number - not ‘Latest’)
AMP 2.5 - 20240314.2
Rust with uMod / Oxide without Container

Problem Description:

First i upgraded the Rust01 instance and it stayed on 2.4.8. I had to upgrade through console. 
After it was 2.5.0 it starts but in AMP it stays in status "STARTING" and no log is available. 
It worked like a charme for a long time. Now it doesn't work anymore. 
And also it doesn't install umod / oxide. I tried to install it manually (copy files) and it's still not starting. 
I don't know what's going on.
"Application State: Starting"

Actions taken to resolve so far:
I updated the server with steam, tried to reinstall umod. No chance.
Updated all AMP instances, all AMP tools and upgraded whole OS.

Also done:

ampinstmgr upgradeall

Tried to install a completly new server, same problem:

All other servers are running. It’s only Rust. Also if i install a new Rust server → Same behaviour.

[Info] Port usage for Rust01 (Rust)
[Info] Instance is currently running.
[Info] LISTENING        8082    TCP     (Core.Webserver.Port)
[Info] LISTENING        2225    TCP     (FileManagerPlugin.SFTP.SFTPPortNumber)
[Info] LISTENING        28015   UDP     (RustModule.Rust.Port)
[Info] LISTENING        28016   UDP     (RustModule.Rust.QueryPort)
[Info] LISTENING        5678    TCP     (RustModule.Rust.RconPort)
[Info] LISTENING        28082   TCP     (RustModule.Rust.AppPlusPort)

Update: uMod/Oxide is working if i install it manually and deactivate the “install umod” option. Server is working like always but AMP doesn’t get over the

"Application State: Starting"

And no chance to see the log in AMP.

Rust takes time to start up.

I don’t think 10 hours starting is normal.
If you had read my text, then you would know that it can’t be that. The server has been running for a long time. The server is started but AMP shows “Starting”.
Please ready the post before do the comment, no offense but it didn’t help if someone just posts the same thing that’s under 90% of every Rust post here.

what does the instance logs look like?

As i said there is no instance log.

I updated to version 2.5 - 20240322.1 and i think that fixed the problem. I never had “Application State: running” that fast on Rust. But i don’t care how fast, before it never came to that state on 2.5 - 20240314.2. For me that’s the fix

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.