Admin Lost Permissions

OS Name/Version: Ubuntu 20.04

Product Name/Version: AMP Release "Halimede"v2.4.0.8, built 10/10/2022 21:18

My AMP Admin user seems to have corrupt permissions I have 7 Instances but can only see 2, cannot make new users, can make more instances (that i cannot see on the web portal but can in adsinstmgr), I tried changing permissions in the web portal but get met with an error that says

There is no single-user role matching this user’s ID. If you have upgraded from a previous version of AMP you will need to re-create this user.

I have tried to upgrade everything with

ampinstmg --nocache upgradeall

I also tried updating the login with

ampinstmgr resetlogin

This happened while editing another user’s permissions, upon logging in the next time i was met with this problem.

Is there a way I can reset the admin permissions or profile?

If you delete the UserInfo and RoleInfo files of the ADS instance while its stopped and use resetlogin again then you’ll fully reset all of AMP’s permissions.