"A backup is already in progress"

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Microsoft Server 2019 GUI

Product Name/Version: AMP Release Halimede v2.4.0.4, built 10/09/2022 16:30

Problem Description: I’ve scheduled a backup of my Garry’s Mod server to take place every day, however I’ve noticed it hasn’t actually been backing up, so I tried to do a manual backup. I’m met with the error of “A backup is already in progress” when I try to start a backup.

Whether it is related or not, I’ve noticed my Garry’s Mod server is showing as starting under the notifications tab at the bottom right, however the server has been running for a while and the notification won’t go away. I’ve tried restarting and reinstalling the server to remove the notification but it persists.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Navigate to Schedule for Garry’s Mod server.
  • Schedule a ‘Take a backup’ through Simple Time Interval trigger to take place at 00:00 every day.
  • Backup should backup at 00:00 every day. But does not. Then try to do a manual backup and receives the “a backup is already in progress” error.

Actions taken to resolve so far: Unable to resolve so far.

Have you checked that instances logs for any backup failures?

Yep, just had a look there.

“[00:54:54] [System:BobbyB Warning] : Scheduled task failed. ‘Event.LocalFileBackupPlugin.TakeBackup’ was not completed. A backup is already in progress.”

The below notification is still there too. Could that be something to do with it? Again, this instance is already running but the notification will not go away.

Do you have any configuration that might be altering the RCON password? The starting notification goes away once AMP connects to the servers RCON.

Not that I can see of. Within the server.cfg in the cfg folder of the Garry’s Mod server, I’ve got the rcon_password. That’s the only relative thing in regards to the RCON. That starting instance notification did seem to be bugging out even with the first installation of the Gmod server, and it seems to have persisted through to the second installation, so I don’t even think it’s trying to start a server now seeing as it’s already up, if that makes sense.

I should add, this seems to be the only server I’m having issues performing backups with. My Minecraft server appears to be fine.

Ah, so you’ve set your own RCON password with rcon_password in server.cfg instead of using AMP to set it?

That’s correct yeah.

Should it be set here instead of the server.cfg?

1 Like

Yeah as RCON is not very secured, AMP handles its password

So with that updated, I’m still getting the same error as initial post “backup is already in progress” with srcds01 still ‘starting instance’ on the home screen of AMP. Tried a restart, still there.

I’ve also added a second Garry’s Mod server with a fresh install and new RCON pass, and still receiving the “a backup is already in progress” error, even though it is a fresh install.