V Rising server wont shut down or restart

OS Name/Version: Debian Linux 10 (buster)

Product Name/Version: AMP Release “Triton” v2.3.3.4, built 06/06/2022 18:55

Problem Description:
The V Rising server instance is working flawless but when trying to restart or shutdown the server the problems start. For starters, the server does not shut down even though AMP are reporting it as shut down.
Application State: Stopped

After the application is “stopped” (not really) then the console output is flooded with this message over and over:

02b0:fixme:file:CancelSynchronousIo (0000000000000074): stub
01c8:fixme:file:CancelSynchronousIo (0000000000000074)

Now the only “solution” is to restart the AMP service entirely (restarting the instance does not work).

Steps to reproduce:

  • Step 1: Start application
  • Step 2: Try to stop application
  • Step 3: Does not shutdown

Actions taken to resolve so far:

Tried to reinstall the application.

Was this instance created using the latest version? It doesn’t work if it was updated form an older version ADS must be in order to create the latest. Also is it in Docker or native?

Yes it was created with the latest version.
I’ts not in a docker container.

Then it could be a variety of issues. Outdated WINE or other dependencies. I’ve been highly recommending making a docker instance for WINE game servers as they can be touchy without exactly what you need and there’s negligible overhead

I will try that then! I’m quite new to Wine so I’ll need to do some reading first.
Thanks for the tip

I did all the reading so you don’t have to. Haha just setup a new instance with the Container option and it’ll do the rest. Just start it and enjoy the game! :slight_smile:

1 Like

Well, that did’nt work. The instance in the docker container won’t even start the application
Log output:

It looks like you’re getting a port conflict. In terminal run netstat -a | grep "your port number" then look in htop to see what process matches that process ID. That’ll tell you what’s using the port. I’ve seen Minecraft using the port for RCON before too.

When the docker instance is stopped the output of netstat -a | grep 25576is nothing and when trying to start the application inside docker the output is

netstat -a | grep 25576
tcp        1      0 *               LISTEN
tcp        0      0 localhost:44616         localhost:25576         ESTABLISHED
tcp       46      0 localhost:25576         localhost:44616         ESTABLISHED

so it seems that the docker container is the only application that are using the port

Try changing the RCON port to something in the 27### range and try again. All it shows is that the port is in use in the log. I had to triple check.

I tried changing it to 27010 instead. Still crashes.

netstat -a | grep 27010
tcp        0      0 *               LISTEN

New log:

Can you share the whole log from when you right click the instance and View Logs? I just want to make sure there’s nothing missing there.


Ahh I think I see something. It’s having trouble parsing the clan size from the ServerGameSettings.json file. Have you edited that yourself? Or imported the settings file? Share it here and maybe I can see why it’s acting up. It should be under save-data/Settings in the File Manager.

Yeah I’ve edited the file manually since the server seems to have trouble understanding the ClanSize variable .

From what I can see there are nothing wrong with the ClanSize variable formatting

You’re not supposed to edit the file by hand at all, you do it via AMPs configuration.

Anything in the GUI shouldn’t be edited by hand like Mike said. It seems the game server doesn’t like the file in the way it is now. I just tried your file on mine and it worked fine though. Have you tried making a fresh instance and starting it without changing any settings at all?

I have deleted the instance and recreated a new one. Now it works but the ClanSize variable wont be saved. I have changed it to 10 but the server reports it as 4.

You need to set Game Settings Ruleset to Custom. Otherwise it tries to use the premade settings files.


Thanks for all your help!

1 Like