Unable to reconfigure instance

OS Name/Version: Debian 11

Product Name/Version: AMP release “Decadeus”

Problem Description:
Trying to edit instance settings in ADS (for example changing Start on boot to off and saving changes) gives a popup saying “Unable to reconfigure instance”.

There is an error in the ADS console as well:

Returned exception from API call ADSModule/UpdateInstanceInfo
[0] (MissingFieldException) : UpdateInstanceInfo method requires ContainerImage(String) argument.
at GSMyAdmin.WebServer.WebAttributes.InvokeMethod (String MethodName, Newtonsoft.Json.Linq.JObject Data, m.Http.IHttpRequest request, ModuleShared.IWebSession Session, ModuleShared.WebMethodsBase MethodsClass, String RawRequest) at GSMyAdmin.WebServer.APIService.InvokeAPI (m.Http.IHttpRequest request, ModuleShared.IWebSession Session, Newtonsoft.Json.Linq.JObject Data, String RequestModule, String RequestMethod, String RawRequest)

Steps to reproduce:

  • Click on edit settings on an instance
  • Make any changes and click save
  • Error pops up

Actions taken to resolve so far:
I have tried to change settings on different instances I have, and made a new instance, but the issues still persists.

I’m having the exact same problem on my Dietpi v8.18.2 (Debian 11 | 8GB RAM ARM Cortex-A72)

It’s a known bug. The workaround is in the instance settings to temporarily enable docker, set the docker image to cubecoders/ampbase then turn off the docker option again. You’ll then be able to save the changes.

Can confirm this has worked for me, although annoying if you have the issue, just follow the comments exactly, and it’ll work. I had an instance locked in suspended mode, now back to working as it should. Cheers for the response!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.