Stuck on "Checking licence key" at reactivation

OS Name/Version: Windows 10

Product Name/Version: Build 09/07/2023
Problem Description:

I setup a new computer to host a minecraft instance as old one is too weak to manage it.
I copied instance folder from old one to new one
Run “ampinstmgr repair” which see old instance
but when running “ampinstmgr reactivate [Myinstance] [Mykey]” it’s stuck at “checking licence key” (with values replaced with instance and my key :grinning: )

Same result with “reactivate all”, using licence at prompt, with cmd or powershell console

One try gave me an error that “ cannot be resolved” and “there is no endpoint listening at Service

others tries stay stucked at license check

Thanks for your help

Sounds like bad DNS. Run nslookup in a command prompt and show me the output.

Here result


Non-authoritative answer:

Do you have any VPN software installed on your system?

Nothing just fresh windows.
After reboot I can see instance but cannot start it

exit code 32 (NO_LICENCE)

Reactivating instance Minecraft2001…

Failure reactivating instance Minecraft2001: Instance Minecraft2001 is busy and cannot be reconfigured at this time.

And command still stuck

edit : killed command, now webfront try to reconfigure but stuck too

Run ampinstmgr stopall then ampinstmgr reactivateall.


I need you to send me an email ( because you’ve compromised your licence key. The previous image you posted with the key visible is still available in the edit history of this post. Your key will have to be reset.

I see :expressionless:
mail sent from address linked to licence

Does your server have multiple IPv4 addresses?

No just one
Defender and microsoft firewall
Even with firewall disable it stuck

Try disabling IPv6 on your system.

It’s disabled
I change key on old one, no issue…
there is something on new that block license check

thanks for your help

edit :
Ok there is a file that stuck process

If I delete instance, I can reactivateall without issues
If I copy folder with instance I want to move, repairall work and detect instance but reactivate stuck at license

What’s the default AMP IP binding set to in Configuration → Networking?

It was, I changed it to network IP

I deleted datastore.dat and licence validation worked

But now when validating file I have this error
[Error] Unable to validate Minecraft2001 - Download cache for 2454 does not exist.

Old and new have not same version…

Edit: not only datastore but AMPVersion file too
after a repair it validate license

I didn’t ask you to change it, was the correct value. Don’t worry about using validate.

Ok found to work

old one was on 2.4.4 that refuse to upgrade by it self
I upgraded from command line ADS and game instance
Copied folder to new server
deleted AMPVersion file
execute repair
execute reactivate

instance start and seems to work

thanks for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.