Startup Issue with Source Dedicated Server - Team Fortress does not start

System Information

Field Value
Operating System Linux - Debian GNU/Linux 11 on x86_64
Product AMP ‘Decadeus’ v2.4.6.0 (Mainline)
Virtualization None
Application Source Dedicated Server
Module srcdsModule
Running in Container No
Current State Failed

Problem Description


Team Fortress does not start - no message in log

Reproduction Steps

  • Installing srcds
  • installing TF2
  • Not start TF2
1 Like

This file is not present for TF2 in .ampdata/instances/TF201/srcds/232250/bin

Use the script generation feature to produce a set of startup scripts where AMP is trying to start up srcds, then run the script outside of AMP to see if there’s any output that gives a clue as to the problem.

I try the startup scripts and I see the error:
“ loaded for Team Fortress
Could not load:
FATAL ERROR: Could not load:”

II found on Google other people who encountered this pb with srcds and and the solution is to install the packages libtinfo5:i386 libncurses5:i386 libcurl3-gnutls:i386
sudo apt-get install libtinfo5:i386 libncurses5:i386 libcurl3-gnutls:i386

I tried that and it’s OK, it works now!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.