Startup Issue with Minecraft - server wont start just say "unable to run"

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on x86_64
Product AMP ‘Callisto’ v2.5.0.8 (Mainline)
Virtualization Docker
Application Minecraft
Module MinecraftModule
Running in Container Yes
Current State Failed

Problem Description

Issue

i just bought my server and ive tried to switch the server version for the mod called DeceasedCraft (https://www.curseforge.com/minecraft/modpacks/deceasedcraft) so its compatible but when i tried that, the server now just say “Unable to run” and i dont know what else i can do to fix it PLEASE HELP I DONT WANNA WASTE MY MONEY

Reproduction Steps

  • ive tried uploding the jar file for the correct version of the game that i needed
  • ive tried switching the settings in the Config. tab
  • ive tried looking in the file manger and changed the version of minecraft that was in those files to there version that i needed

This is not Hostinger support, this is the forum for AMP.
I suggest that you read your console/log to figure out why your server isn’t starting.

what is the error message u get in the console?

I don’t get an error, you’ll have to read in your own console and/or log to find out what’s going wrong.