New install - Java missing

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Ubuntu 22.04 LTS

Product Name/Version: AMP 2.3.3.4

Problem Description: New customer here. Fresh install per your bash script. Everything looked good. Went to spin up a Minecraft instance and that went well. Tried to start it and got told that Java is not installed. Tried to update it and got the same message. I remember the script output running two different Java installs without error.

If you're sharing console output, logs, or commands you have run, please make sure to use code tags 
(3x backticks for blocks, 1x backtick for a single line) to help make posts readable. This also
provides syntax highlighting.

Steps to reproduce:

  • Run your bash script
  • Create default MC instance
  • Try to update it
  • Get Java is not installed error message

Actions taken to resolve so far: Rebooted server, no change

Update: I fixed it myself by manually installing openjdk-8. Then I tried to get Spigot going and that failed saying it tried to compile but the jar is missing. After some digging I read that BuildTools.jar requires Java 17, so I manually installed openjdk-17. Now I can manually build 1.19.

Not a great first impression.

Do you have Java in /usr/lib/jvm ? Normally AMP installs the Adoptium builds during installation.

I’m at work now and have no idea where Java is installed. The OS was Ubuntu 22.04 LTS freshly installed on Proxmox. AMP was the only thing installed on it after initial update. The Java installs obviously failed during AMP setup for whatever reason. As indicated, manual install of OpenJDK worked fine. Have you guys validated that AMP installs on 22.04? Any logs you need to see?

Edit: This forum is strange. I can’t just add another reply, I have to edit this one. Anyway, no Java there. No such directory.