How do I change the default port that the web UI uses?

Arco (Arch) Linux
AMP version 2.4.4

I don’t see anything in the web UI nor in any of the documentation that says how to change that port. Googling doesn’t come up with any useful information either.
I don’t want to change the auth port I want to change the webui port.

It’s a lot of work. The AMP instance that provides the main web interface is also the auth server, so changing the port requires reconfiguring every existing instance with the new auth server details as well as a pile of setting changes. It’s something to be avoided if at all possible.

Why are you wanting to change the port of the web interface?

Because I tried changing the port of Nextcloud since it seems to at least need to run on 8080 for setup and I cannot change that port. Maybe I might be able get by by only temporarily disabling AMP but either way I don’t think that the webui should run on port 8080.

nextcloud uses the default port 80 of the httpd but you shouldn’t be running a web host and amp on the same server as they do clash with the httpd.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.