CSGO Server instantly goes into unable to run

Note - If you do not fill in every section below, your post won’t be answered - you must provide the steps you have followed so far and the actions you’ve already taken. Make sure to remove this notice from your post too.

OS Name/Version: Ubuntu Server 22.04

Product Name/Version: v2.4.3

Problem Description:

I freshly installed the os and directly after AMP. Then i created a CSGO instance, updated (and installed) the CSGO Server, gave my GSLT and Workshop API, changed Map to Nuke and the ip from to the local ip adress.

After Starting, it goes immidetaly to “unable to start”.

LOG 1 + 2: AMP LOG 1 + 2 - Pastebin.com
LOG 3 + 4: AMP LOG 3 + 4 - Pastebin.com

Actions taken to resolve so far:

See upper steps.
And: Restarted Instance, Updated, Restarted Server, Deleted one and created a new Instance

Please come back to me if you need more information.

This was solved in Discord by using Docker mode.

I was having the same issue and switched to Docker mode just for CSGO. Why is this happening?

BTW - Using Docker mode has solved my problem as well.

1 Like

Most likely you’re just missing some dependency on your system that the game server needs to run. By using docker you have a premade container will all of them included.

Just for future reference.
CSGO server on linux came with outdate libs. On newer linux its get insta crash because old libs dont have support anymore. You can fix it by deleting the old lib file from csgo server libs folder(I dont remember the name of the file). The second option is by running in docker container. (IF someone really need the filename because they dont want to run the server on container i will check the file name)

This would be cool if you have time. I would rather not run docker if not needed. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.