Connectivity Problem with Application Deployment - Rust connection problem

System Information

Field Value
Operating System Linux - Debian GNU/Linux 12 on aarch64
Product AMP ‘Decadeus’ v2.4.7.0 (Mainline)
Virtualization None
Application Application Deployment
Module ADSModule
Running in Container No
Current State Indeterminate

Problem Description

Issue

Hi,
I successfully installed and configured AMP to be run as a controller on a Raspberry PI 5 and a target with Rocky Linux hosted on a Hyper-V VM. Whenever I create a Minecraft instance I can log in with no problem, but when it comes to games like Rust (Steam-based) it says that there’s an error with the app ID. I’m trying to set up everything to be run at least in LAN (since I’ll be using a VPN to let my friends connect to my network later on). My network setup includes a UDM SE Network Console (with HTTP, HTTPS and port 8080 already forwarded for the Raspberry), and the network settings in my AMP panel are 0.0.0.0 for everything. When I try to connect with my local address, it still says there’s an error with my app ID. Everything is run in Docker containers.
I’m not able to think of a way to figure this out at the moment, so any help is appreciated, thanks.

Reproduction Steps

  • Setup AMP Controller (Raspberry OS) + Target (Rocky Linux on Hyper-V)
  • Create a Rust instance
  • Try connecting after the 20 minutes server warm-up

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.