Configuration with Application Deployment - Scheduled tasks are not running

System Information

Field Value
Operating System Linux - Ubuntu 22.04.3 on x86_64
Product AMP ‘Decadeus’ v2.4.7.0 (Mainline)
Virtualization None
Application Application Deployment
Module Any
Running in Container No
Current State Indeterminate

Problem Description

Issue

Running into an issue where scheduled tasks I have created in any instance do not run when scheduled to do so.

I’ve confirmed the server (Ubuntu 22.04) is configured correctly to the right timezone and the time/date is correct.

Manually triggering the scheduled task does perform all functions correctly. it just never runs automatically.

Reproduction Steps

  • Verify server time is set to correct timezone (timedatectl)
  • Verify server displays the correct settings for configured timezone and time is correct
  • create a scheduled task on an instance with some task to run
  • observe that scheduled task does not run when time is reached
  • Scheduled task DOES run when manually triggered and performs all functions correctly

Update After Further Testing

After further testing, it appears that scheduled tasks are running using the timezone of UTC 0, rather than the server’s configured timezone setting

example, server time is set for America/Phoenix (UTC -7), and shows a time of 8:40 am.
Scheduled task set to run at 8:45am
Task doesn’t run when server time reaches 8:45am

update task to run at 15:50am (UTC 0 (8:50am UTC-7), task does run when server time reaches 8:50am.

Scheduled tasks should run based on server local timezone setting OR provide some feedback to UI indicating to user that task is scheduled to run at xxx time, but will run at UTC time instead

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.