Can't reach amp webserver from local network

OS Name/Version:
Fedora Linux 36 (Server Edition)

Product Name/Version: (Always use the full version number - not ‘Latest’)

Amp Instance Manager v2.3.4.3

Problem Description:

I have this setup to use a domain, and I can reach it from outside of my local network. However, from inside my network that same domain just brings me to my router config page. This part is probably a case of me needing to learn how to use my router better, but if i try to use the local ip address of amp with port 8080 example: XXX.XXX.X.XXX:8080 it still will not reach the webserver. Can anyone give me some pointers on how to fix this?

Steps to reproduce:

  • Step 1:
    Install amp and set to a domain.
  • Step 2
    Try to reach domain from local ip and domain

Actions taken to resolve so far:

I have tried setting resetting with ampinstmgr rebind to mylocalip:8080, but it still has not worked.

You need to make sure your router supports hairpin NAT. If your router doesn’t support it, you should bind ADS to which will let you access it regardless.

1 Like