BepinEx Fails to Install - Valheim Instance

OS Name/Version: Ubuntu 20.04

Product Name/Version:

Problem Description:
BepinEx will not install

Steps to reproduce:

  • Step 1 - Install Valheim Instance
  • Step 2 - Enable BepinEx in “SteamCMD and Updates”
  • Step 3 - Start instance to generate Valheim server files
  • Step 4 - Stop instance, then Update
  • Step 5 - BepinEx does not install

Actions taken to resolve so far:
I have tested this in existing Valheim instances and new Valheim instances in AMP with the same result. I suspect it may be related to a similar bug that users of LinuxGSM have reported related to this error:

ERROR: object '' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

It is currently being tracked in the LGSM github under the following issue ID

Just going to point out that you’re using an old version of AMP and should update. Also, which architecture is being used? You can see this on the “Support” tab within AMP.

I’ve tried to update AMP in the web UI, but my instance says that it’s the latest release :confused:

I did make sure that I at least had all current updates for my Ubuntu, and have rebooted the VM itself. According to AMP, the system architecture is x86_64 and the platform CPU is an Intel Xeon E5-2660 v4, with 8 GB RAM.

My apologies, I should have dove into the release notes, not realizing that my AMP instance manager was out of date. Taking care of that now.

edit 2
I have attempted to update ADS following the documentation, but It doesn’t seem to update the AMP instance.

root@localhost:~# sudo su -l amp
  CubeCoders AMP  💻amp@localhost  📁~  ampinstmgr upgrade ADS
[Info] AMP Instance Manager v2.1.0.12 built 02/03/2021 12:26
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] Stopping Instance: 'ADS01'
[Info] Stopping instance ADS01...
[Info] Requesting soft-stop...
[Info] Waiting for instance to stop...
[Info] Instance was shut down gracefully.
[Info] Instance ADS01 has stopped.
[Info] Upgrading instance ADS01
[Info] Using cached archive: /home/amp/.ampdata/instances/
[Info] Upgrade successful
[Info] Waiting for AMP instance to start...
[Notice] AMP instance ADS01 is now running.
  CubeCoders AMP  💻amp@localhost  📁~ 

You’re on an ancient version of the instance manager. Update the instance manager first before trying to update ADS or any other instance

I honestly thought that is what I was attempting… reading compression fail on my part

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.