System Information
| Field | Value |
|---|---|
| Operating System | Linux - Debian GNU/Linux 13 on x86_64 |
| Product | AMP ‘Proteus’ v2.8.0.4 (Mainline) |
| Virtualization | VMware |
| Application | Application Deployment |
| Module | ADSModule |
| Running in Container | No |
| Current State | Indeterminate |
Task
upgrade amp instances
Problem Description
Issue
I had a Debian Bookworm machine running AMP that managed my local Minecraft servers. I upgraded the VM to Trixie by modifying sources.list and doing full-upgrade. AMP instance manager itself starts fine, but the game instances won’t boot. I tried to update AMP itself from the CLI but get notices that my Pro license can’t be found. I copy/pasted part of the terminal response of the upgrade command, this is the id of the managing ADS01 instance;
[07:59:35] [System Info/8] : AMP Instance ID: 29839acb-cc87-4352-a244-b09adea89fdf
[07:59:35] [Licencing Error/8] : Unable to load licence for AMP Professional Edition - NoMatchingMachineId
Reproduction Steps
- Install amp on Debian 12
- Change /etc/apt/sources.list to debian trixie
- sudo apt update
- sudo apt full-upgrade -y
- reboot VM
- Open AMP web panel and start a MC instance (fails)
- Attempt to update/upgrade AMP from cli using sudo su -l, getamp upgrade
- Process starts but complains license isn’t valid