AMP Port not working

OS Name/Version: Ubuntu 22

Product Name/Version: The version of AMP? V2.4.4

Problem Description: I have installed the AMP on a Ubuntu machine and got the server to work and I am able to connect to it from my home network. But I am not able to connect it from another network and I am not able to access the web ui from another network.

I have a running minecraft and other zomboid server up and running and I have opened the port the same way and it will not work.

Actions been taken to resolve so far:
I have opened different ports on my router, and I have allowed more ports on the Ubuntu machine

The server is up and I can connect to it with my own PC and with a laptop on the same network. But when using another wifi it will not work and I am not able to reach either the server or the website.

I have a Minecraft server running with another panel in Linux and zomboid with a windows 11 PC. Both are virtual ones that I have on a server PC at home. People are able to connect to those and access those website panels. I have done nothing different with the ports on the AMP and I cannot get it to work.

If I would setup a Linux and download Steamcmd and all that, I can have it up within 30 min maybe. But will not have the web UI that you have here. That is the one I want but can’t get it to be open from the outside.

This is the issue I need help with

Running an application within AMP is no different from running it outside of AMP in terms of connectivity.

If you can access the game from another device on the same network using your internal IP, then the game server, AMP, and the servers firewall are all functioning correctly and configured correctly, otherwise you would not be able to connect. This means that failure to connect externally is down to bad port forwarding.

If you cannot access it from another device on the same network, then something is wrong with the local firewall configuration.

Have you checked that ampinstmgr dumpfirewall shows all the expected firewall rules? And that the Windows Advanced Firewall control panel reflects that?

If I use the command

Run it as root to confirm, but I’m pretty sure this is going to turn out to be a misconfigured firewall.

If it has no rules as root, run ufw status - if it says “inactive” then that’s the problem.

How about this?

So your zomboid server is on port 14444/14445 - is that a what you’re connecting on?

Yes, I changed it from 19132 to 14444 and I opened those ports on my router to that machine as well as I’ve done with the other servers.

I started another linux host and tried other command to see… Why is it on from default or what is going on?!

That’s just AMP starting up. It doesn’t show you starting the actual game server. Did you double click the instance to manage it like the wizard said?

Yes? I went to the local ip and started an instance? Because I can join the server on the local network

If you can join it on the local network but not remote then it’s bad port forwarding. Double check the ports being forwarded, the protocol, and the internal IP being used. AMP doesn’t have anything to do with connectivity beyond sorting out the firewall rules which are correct.

Hello Mike… I tried now with 2 ubuntu machines and first was maybe a trial thing… So I did new one while I was typing here and did not work. So I opened up my windows machine and installed it over there… Same thing, just ran the install and started a server like with the ubuntu machines… To my suprise it works!!!

So why does it work from out the box from a windows machine but not the ubuntu. So clearly, the port fowarding is not the problem. It has something to do with ubuntu and the AMP…

AMP has a feature that will generate startup scripts that allow you to start an application outside of AMP the exact same way that AMP itself starts it. See the “Diagnosing Startup Issues” segment of this guide.

By starting the application outside of AMP, you can see whether or not the application behaves the same way without AMP involved. If it behaves the same, you can therefore determine that AMP is not the issue.

Your UFW rules don’t show anything that would block any incoming traffic, and since you can connect on the local network then it’s nothing to do with that machine.

The only possible difference I could think of - is if the router you’re using is some cheap ISP provided router that will only properly port forward to machines that advertise over DNS. The way you’d normally know this is if the routers interface only lets you pick from a pre-filled list of systems to forward to rather than an internal IP.

Your router and/or port forwarding is undoubtedly, 100% the culprit here. So what I’d like to see next - is the output of the command ip addr on the system running AMP, as well as your port forwarding rules on your router showing that ports 14444/14445 UDP are forwarded to the internal IP that shows up there.

Please tell me why the router/port forwarding is wrong to 100% when clearly having a ubuntu with a another manager with webpage work with Minecraft and people can connect.

Why do I have an Windows 11 with another “manager” running Zomboid working and people can connect to the server.

Why have I been able to setup several ubuntu and windows machines and no one have had problem connect including me.

Now when I run AMP with Ubuntu it does not work, but running it with an window machine it works. It has nothing to do with the router/port forwarding.

This is an issue with AMP and Ubuntu together…

Please believe me when I say your issue is not remotely unique, nor is anything about your setup. There are tens of thousands of AMP installations, very few people have a setup so unusual, or so different that theirs is special in any way. So what applies to one setup almost always applies universally. Whenever someone is in this situation where they can connect using a different device on the same network, but not remotely - I’ve yet to encounter a situation where it wasn’t a routing or port forwarding issue. You wouldn’t be the first person (nor will you be the last) to push back at my insistence that attention is focused there.

So please, if only to humour me - show me the output of ip addr on the host running AMP, along with a screenshot of your port forwarding rules.

If I am satisfied that all is well in that regard, then we’ll move on to looking at what else could be up.

The other thing that would be helpful is a full copy of all the diagnostic information shown within the ‘Support’ tab inside the AMP instance. You’ve not mentioned yet if you’re having AMP use Docker containers for the instances which may also be pertinent.

I am guessing you want the command on the ubuntu machine with the problem.

Thank you, followed by a screenshot of the relevant port forwarding rules and the information from the Support tab within the AMP instance I mentioned.

Oki see image v

Your screenshot earlier indicated that instance ProjectZomboid01 was occupying ports 14444 UDP and 14445 UDP, no TCP ports are used.

If I’m not mistaken, that screenshot of your port forwarding is from an ASUS branded router, correct? So where I see 14444:14445 - it looks like that’s in the column marked Internal Port in the table’s header.

If so, that is incorrect. It should be in the External Port column. So it should look like this:

The “Internal Port” (sometimes called Local Port) should be empty. The “Source IP” (sometimes called Remote IP) should also be empty.

Seeing the full table with all of it’s headers would be more helpful though if I am not correct.